Flashing Orin NX from docker stuck on "Waiting for target to boot-up"

I am trying to flash my Orin NX through a docker container. All of the steps that I use to set it up are working without a docker container. But when I execute them within a docker container it gets stuck on “Waiting for target to boot up…”
I am using these steps for flashing: Quick Start — Jetson Linux Developer Guide documentation
Here are the logs:
Flashlog (213.6 KB)
I run the docker container with the following command: sudo docker run -v /dev/bus/usb/:/dev/bus/usb/ --privileged -it flash_test
Ive tried to format the SSD either with and without empty ext4 partition.
I thought maybe it is not detecting my Jetson due to container permissions, but when I check lsusb I can see the device after the command fails. Also my laptop is able to see the SSD through the Jetson. I would assume its a docker setting but what could it be…

Thanks in advance!

Please also try to dump the flash log from the device side. What you shared is host side.

Jetson_flash_log (88.1 KB)

Hereby the Jetson log. It seems it booted up way before the timeout hit. So I think its a permission thing. But I cant figure out what. Could you try the above dockerfile and see if it works for you?

Are you sure the host side log still tells you “Waiting for target to boot-up…” and then timeout?

If so, then I think host side cannot detect your jetson through usb interface. lsusb on your host does not detect it.

Is it a Orin NX devkit or a custom board? Or you are not sure about it?


Its an Orin NX in Xavier NX development kit carrier board. Yes that was already my thought. Lsusb does detect the Orin. What may be the fix?

Ive found the solution
If you do not specify the --network usb0 it will work without issues.
sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 \ -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \ --showlogs --network usb0 p3509-a02+p3767-0000 internal

I checked the l4t internal script and it seems external mode somehow doesnt properly work when its specified in a docker container.

Hi, I’m trying to do something similar, and trying to replicate your environment, could you publish the dockerfile

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.