Flashing Problem (Host+Target)

Hi,
When trying to flash the device, below error is observed.
Failed to bind partitions!
You can see the related log part below, how can I fix the problem and flash the chips, thanks!

[2019-11-02 19:03:32,475 root DEBUG inforom_data_handler.py 110 18176] Aurix port /dev/ttyUSB3 is open
[2019-11-02 19:03:35,579 root CRITICAL runner.py 37 18176] Failed to bind partitions!
[2019-11-02 19:03:35,580 root DEBUG runner.py 38 18176] Exception info:
Traceback (most recent call last):
File “/home/otonom/nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_E3550/DriveSDK/pdkinstaller/module/pdk_bind.py”, line 87, in pdk_bind
board_rev = inforom_obj.get_Target_PCB()
File “/home/otonom/nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_E3550/DriveSDK/pdkinstaller/module/inforom_data_handler.py”, line 86, in get_Target_PCB
self.__get_Inforom_dump()
File “/home/otonom/nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_E3550/DriveSDK/pdkinstaller/module/inforom_data_handler.py”, line 124, in __get_Inforom_dump
trim_start = Info_data.index(self.Inforom_start_byte)
ValueError: ‘4D’ is not in list

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “./pdkinstaller”, line 769, in
root_pwd = arguments.sudo_pwd
File “/home/otonom/nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_E3550/DriveSDK/pdkinstaller/module/pdk_bind.py”, line 101, in pdk_bind
raise errors.FailedToBindPartitionsError()
module.errors.FailedToBindPartitionsError: Failed to bind partitions!
[2019-11-02 19:03:35,582 root CRITICAL runner.py 43 18176] pdkinstaller cannot continue! Check the log file for details: /home/otonom/nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_E3550/DriveSDK/pdkinstaller/pdkinstaller.log
[2019-11-02 19:03:35,582 root DEBUG runner.py 60 18176] Cleaning up…
[2019-11-02 19:03:35,582 root DEBUG utilities.py 124 18176] Deleting temporary directories…
[2019-11-02 19:03:35,583 root DEBUG runner.py 62 18176] Closing the log file.

Dear sozekmok,
Could you please attached ~/.nvsdkm/logs folder and ~/.nvsdkm/sdkm.log files to get more insights.
I assume you have checked the prerequisites at https://developer.nvidia.com/drive/downloads and has no issues with internet.

Yes, I can confirm that we meet prerequisites and have no issues regarding the internet.
I was using the AGX without any problems even on vehicle. But suddenly, first we observed the issue on the ticket that I have opened up this morning. I see that you also replied to that.
https://devtalk.nvidia.com/default/topic/1065953/general/agx-tegra-a-amp-tegra-b-command-line-not-showing-up/
In order to solve this I tried flashing the Drive OS only to see this flashing problem.
You can see the logs that you have requested at the attachment.
logs.zip (692 KB)

Dear sozekmek, The log shows to look at DRIVE_Software_9.0_Linux_hyperion_E3550/DriveSDK/pdkinstaller/pdkinstaller.log for more details. Could you attach that file

Dear SivaRamaKrishna,

You can find the log you have requested at the attachment.
pdkinstaller.log (33.1 KB)

Dear sozemek,
Thank you for sharing logs. We will check and get back to you.

Dear sozekmek,
It seems there is conflict with current driveworks installed on host machine.

2019-11-02 19:00:28.742 - error: dpkg: regarding .../driveav-v2.0.2081_15209602_20190506_36b127f_nopdkgcid_linux-amd64-ubuntu1604.deb containing driveav:
2019-11-02 19:00:28.743 - info:  driveworks conflicts with driveav
2019-11-02 19:00:28.743 - info:   driveav (version 2.0.2081) is to be installed.
2019-11-02 19:00:28.744 - info:
2019-11-02 19:00:28.744 - info: dpkg: error processing archive /home/otonom/Downloads/nvidia/sdkm_downloads/driveav-v2.0.2081_15209602_20190506_36b127f_nopdkgcid_linux-amd64-ubuntu1604.deb (--install):
2019-11-02 19:00:28.744 - info:  conflicting packages - not installing driveav
2019-11-02 19:00:28.883 - error: Errors were encountered while processing:
2019-11-02 19:00:28.884 - info:  /home/otonom/Downloads/nvidia/sdkm_downloads/driveav-v2.0.2081_15209602_20190506_36b127f_nopdkgcid_linux-amd64-ubuntu1604.deb (edited)

Could you check flashing from another host. If that is not possible, please check uninstalling the old packages via sdkm from host and check flashing.
Also, please check compatible host kernel version. For more details about known flashing issues and work arounds, please check https://developer.download.nvidia.com/driveworks/secure/docs/DRIVE_9.0_Release_Docs/NVIDIA_DRIVE_AGX_Developer_Kit_Flashing_Technical_Bulletin.pdf?CuJNeiuHYSq_fEf7vwMx2_XRyGxf7VusAPJYB0Di4kz7LCETt1fgA4OCILmP3PGKasbczF-cwUenrPXiQxdFVWE038QnbOfnRGt85aKty_thNOC7KSe5ohxqrTd0BEeOmANxI1tMKFlyjcJHdmiwlyKyxIX5JvwEYbjgyIM93TEuLgIsBFszVdKvZRyXZhL5LW2dlbuzPmYUCCZG7JR_4XZ5bb6CIrt2m0Ue

Dear SivaRamaKrishna,

I have tried flashing from a different host and now I am experiencing another problem. You can see its log at the attachment. Flashing aborts with an error around %95.
I do appreciate your swift support, thanks for that. Hopefully we can find a way around this.
pdkinstaller.log (994 KB)

Dear sozemek,
I could see “error-adb-timeout" in pdkinstaller.log . We provided a work around for it in Section 2.6 in our flashing technical bulletin shared in earlier message. Please check that. If that does not help, please share ~/.nvsdkm/logs and ~/.nvsdkm/sdkm.log on while flashing using new host. Also, please share host machine linux kernel version

Dear SivaRamaKrishna,

My host machine linux kernel version is 4.15.0-66-generic.
Also, I have checked the link that you have provided. I understand you are refering to “Power Sequencing Required for Certain HDMI Monitors”, but right now I don’t have any HDMI monitors connected.
You can find the logs attached.
logs.zip (454 KB)

Dear sozemek,
Could you please run sudo udevadm monitor on host machine terminal and check flashing. Please provide both flashing logs and terminal output check events?

Dear SivaRamaKrishna,

You can find the kernel log below, and the flash tool log at the attachment.

KERNEL[41043.234720] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
KERNEL[41043.235841] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
UDEV  [41043.237087] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
UDEV  [41043.247100] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
KERNEL[41048.937154] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1 (usb)
KERNEL[41048.937706] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1/3-2.1:1.0 (usb)
UDEV  [41048.958220] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1 (usb)
UDEV  [41049.973883] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1/3-2.1:1.0 (usb)
KERNEL[41054.565245] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
KERNEL[41054.565545] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
UDEV  [41054.582955] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
UDEV  [41055.592837] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
KERNEL[41062.690286] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1/3-2.1:1.0 (usb)
KERNEL[41062.690705] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1 (usb)
UDEV  [41062.693244] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1/3-2.1:1.0 (usb)
UDEV  [41062.701318] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1 (usb)
KERNEL[41063.017278] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1 (usb)
KERNEL[41063.017594] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1/3-2.1:1.0 (usb)
KERNEL[41063.017982] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
KERNEL[41063.018393] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
UDEV  [41063.020363] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
UDEV  [41063.028571] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
KERNEL[41063.345223] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
KERNEL[41063.345786] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
UDEV  [41063.363245] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
UDEV  [41063.367692] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1 (usb)
UDEV  [41064.375312] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1/3-2.1:1.0 (usb)
UDEV  [41064.375417] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
KERNEL[41079.585820] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1/3-2.1:1.0 (usb)
KERNEL[41079.586066] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1 (usb)
UDEV  [41079.587462] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1/3-2.1:1.0 (usb)
UDEV  [41079.600416] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.1 (usb)
KERNEL[41079.728322] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
KERNEL[41079.728555] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
UDEV  [41079.729921] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
UDEV  [41079.736079] remove   /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
KERNEL[41081.188833] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
KERNEL[41081.190080] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
UDEV  [41081.208065] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2 (usb)
UDEV  [41082.227199] add      /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.2/3-2.2:1.0 (usb)
KERNEL[41099.036497] change   /devices/virtual/block/loop4 (block)
KERNEL[41099.036619] change   /devices/virtual/block/loop5 (block)
KERNEL[41099.280116] change   /devices/virtual/block/loop4 (block)
KERNEL[41099.281488] change   /devices/virtual/block/loop5 (block)
UDEV  [41100.755175] change   /devices/virtual/block/loop4 (block)
UDEV  [41100.755222] change   /devices/virtual/block/loop5 (block)
UDEV  [41100.758692] change   /devices/virtual/block/loop5 (block)
UDEV  [41100.759248] change   /devices/virtual/block/loop4 (block)
KERNEL[41126.101200] remove   /radix_tree_node(2216:systemd-hostnamed.service) (cgroup)
KERNEL[41126.101229] remove   /cred_jar(2216:systemd-hostnamed.service) (cgroup)
KERNEL[41126.101240] remove   /ext4_inode_cache(2216:systemd-hostnamed.service) (cgroup)
KERNEL[41126.101251] remove   /proc_inode_cache(2216:systemd-hostnamed.service) (cgroup)
KERNEL[41126.101262] remove   /inode_cache(2216:systemd-hostnamed.service) (cgroup)
KERNEL[41126.101274] remove   /dentry(2216:systemd-hostnamed.service) (cgroup)
UDEV  [41126.102937] remove   /cred_jar(2216:systemd-hostnamed.service) (cgroup)
UDEV  [41126.102964] remove   /dentry(2216:systemd-hostnamed.service) (cgroup)
UDEV  [41126.102985] remove   /ext4_inode_cache(2216:systemd-hostnamed.service) (cgroup)
UDEV  [41126.103166] remove   /radix_tree_node(2216:systemd-hostnamed.service) (cgroup)
UDEV  [41126.106441] remove   /proc_inode_cache(2216:systemd-hostnamed.service) (cgroup)
UDEV  [41126.106473] remove   /inode_cache(2216:systemd-hostnamed.service) (cgroup)
KERNEL[41730.572579] change   /devices/virtual/block/loop5 (block)
UDEV  [41732.807219] change   /devices/virtual/block/loop5 (block)
KERNEL[41732.996971] change   /devices/virtual/block/loop4 (block)
UDEV  [41732.998106] change   /devices/virtual/block/loop4 (block)
KERNEL[41772.755244] change   /devices/virtual/block/loop4 (block)
KERNEL[41772.776987] change   /devices/virtual/block/loop5 (block)
UDEV  [41775.143034] change   /devices/virtual/block/loop5 (block)
UDEV  [41775.143606] change   /devices/virtual/block/loop4 (block)
KERNEL[42417.596479] change   /devices/virtual/block/loop5 (block)
KERNEL[42417.952317] change   /devices/virtual/block/loop4 (block)
UDEV  [42420.556052] change   /devices/virtual/block/loop4 (block)
UDEV  [42420.556957] change   /devices/virtual/block/loop5 (block)

pdkinstaller.log (980 KB)

Dear SivaRamaKrishna,

Because of this issue, we are behind our time schedule hence I wanted to remind the issue. How can I solve this issue, do you have a solution? Thanks!

Dear sozemek,
As I understand, the adb devices are not reachable while attempting flashing and hence you see adb timeout in logs. Could you please file a bug with all the logs and share it here. We will look into it.

Dear SivaRamaKrishna,

Thanks for letting me know! I hope someone can find a solution for this.

Dear sozekmek,
Did you file bug, If so , please share bug ID here for follow up.
Please login to https://developer.nvidia.com/drive with your credentials. Please check MyAccount->MyBugs->Submit a new bug to file bug.

Dear SivaRamaKrishna,

I have submitted a bug on the day that you have requested, 7th of November. Since 4th of November I am waiting for a solution and since 7th of November I am waiting for my bug to be resolved. Bug ID is 2752647. I think if you reach me via email we can find a solution for this as fast as possible, maybe through remote connection to the device.

Dear sozemek,
Is it possible to check from another Host PC(which never used for flashing) as I think some settings have messed up your system. Also, did you ever flash the board with anything other than DRIVE SW 9.0?

Dear SivaRamaKrishna,

You have requested flashing from a different host PC on 5th of November and I did provide my feedback then. Yes, I have used another host PC that I have never used for flashing before. With that, I am receiving “error-adb-timeout” error. I have also tried flashing Xavier A and B separately with this host PC but kept on releasing the same error.
For the second question, no we haven’t flashed the board with anything other than Drive SW 9.0.

Hi sozemek,

Due to issue is under tracking at bug 2752647, I’m closing this topic now.