Flashing problem - Jetson TX2 with carrier board Auvidea J90

Hello all,

I’ve got problem with my Jestsons - I can’t flash file system to TX2. I am using Jetson TX2 with auvidea J90. I’ve downloaded Jetpack 3.3, replaced necessary files (from auvidea firmare), put my TX2 into recovery mode (command lsusb shows NVidia Corp), but the installer still says :
“error: probing the target board failed”

I’ve tried 2 diffrent Jestons and 2 different J90 boards, different USB ports (every time Jeston comes up as NVidida Corp) but every time i get the same error. Flashing OS to dev board Jetson worked just fine.

I’m using ubuntu 16.04 (not VM)
I’m connecting J90 with USB cable included to devKit.
I’ve tried to connect to board via UART0 - the MCU connects.

Can anyone help me?

I have no experience with the alternate carrier board, but it sounds like it should have proceeded with the flash. You might want to run the flash on command line instead and log. Here is a description of command line flashing (be sure to still run any kind of device tree or other update which is specific to the carrier board):

In that URL note that the actual flash command pipes to “tee” when logging:

sudo ./flash.sh -S 29318MiB jetson-tx2 mmcblk0p1 <b>2>&1 | tee log_flash.txt</b>

Post the log here. You can attach it to an already existing post. If you hover the mouse over the quote icon in the upper right of your existing post, then a paper clip icon will show up. This is how you can attach a file.

There have been cases where a host’s port does not work for some mysterious reason, but that is a fairly rare event.