Flashing problems with Jetson AGX Xavier carrier board and custom board

I’m working on a project where we’re adding features to a system based on the Jetson AGX Xavier P2888-0004 (32 GB)

We’re at the stage where we need to flash. To get familiar with the procedure I ran through the quick start instructions for flashing the SOM for the carrier board. It wouldn’t work with L4T 32.5.1 (it would get caught in a bootloop, cycling between the nvidia logo w/ a white background and the start of the log output) but worked just fine with L4T 32.4.2. Why would the same procedure lead to different outcomes here?

The next step is flashing the older version of the hardware with a provided set of:

  • 2 .cfg files
  • 1 .conf file
  • 3 .dtsi files used to make the .cfg files using the python script

that we know have worked correctly with this exact board already. I flash the board using the following procedure:

  • SOM plugged into carrier board and plugged into computer running Ubuntu 18.04, using the older L4T 32.4.2
  • the 2 cfg files are placed into the bootloader directory
  • the conf file “revision1.conf” is placed in the “Linux_for_Tegra” directory
  • put the jetson into recovery mode and verified using lsusb
  • “sudo ./flash.sh revision1 mmcblk0p1” leads to “… flashed successfully. ***”
  • pull usb, then barrel jack

when i plugged the SOM into the revision1 hardware i had the same bootloop (cycling between nvidia logo on black and a black screen) I repeated the same procedure but left the SOM in the carrier board to see if it would boot into the setup like it would when flashing the conf associated with the carrier board. same bootloop as before. Is there anything incorrect about my procedure?

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

So is there any carrier board that can work on your side now? From the description, I still don’t know whether rel-32.4.2 is working or not. It sounds like it is working but also not working. Sorry for my poor English reading.

I would suggest you can dump the serial console log from uart first.