Flashing specific internal qspi partition with initrd

I read the README_initrd_flash.txt

it provides the following example regarding flashing specific partition:

For flashing kernel-dtb partition on external device:
$ sudo ./tools/kernel_flash/l4t_initrd_flash.sh
–external-device nvme0n1p1
-c ./tools/kernel_flash/flash_l4t_external.xml
-k kernel-dtb --external-only jetson-xavier mmcblk0p1

in addition it provides the following example to flash internal qspi:

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1
-c tools/kernel_flash/flash_l4t_external.xml
-p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml --no-systemimg” --network usb0

2 questions please:

  1. How can I flash a specific partition in internal qspi? specifically I wish to flash the bootloader partition after modifying uefi binary

  2. what is the meaning of “–no-systemimg” flag in the qspi flash command?
    the systemimg is the APP partition and its not going to be flashed into the internal qspi in any case



You don’t need initrd flash to flash QPSI memory; flash.sh in enough here.
Do it like this:

sudo ./flash.sh --no-systemimg -c bootloader/t186ref/cfg/flash_t234_qspi.xml jetson-orin-nano-devkit mmcblk1p1

I think you are right.
It’s for devices with both QSPI and eMMC, so you don’t need it on devices having only QSPI.

Thank you for your answer.

  1. I don’t have emmc so what to write instead of mmcblk0p1?

  2. what is the exact partition for flashing uefi only (in the internal qspi)

Just use whatever storage device you have.

Check contents of Linux_for_Tegra/bootloader/t186ref/cfg/flash_t234_qspi.xml, it’s A_cpu-bootloader and B_cpu-bootloader.
(There are two partitions because of this: Update and Redundancy — Jetson Linux Developer Guide documentation)

I apologise for re-asking same question, I just want to make sure I understood:
in the following command:

sudo ./flash.sh --no-systemimg -c bootloader/t186ref/cfg/flash_t234_qspi.xml jetson-orin-nano-devkit mmcblk1p1

the “mmcblk0p1” is:

  1. just a “place holder” in the command and its not really matter whats written in its place because its going to be ignored either way and flash only internal qspi
  2. has to be a real device otherwise the command will fail

I want to make sure only the internal qspi will be flashed

This option affects the device being written into /boot/extlinux/extlinux.conf, but as you are only flashing the QSPI memory, nothing should be changed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.