Flashing system image with Jetpack components using flash tool


I want to know if I can use flash.sh tool to install the OS and skip SDK manager?

Because i want to automate this procedure and i already have a prepared system image and after the initial OS flashing i will use flash.sh tool to flash the backup system image.

The end goal is that i want to automate this procedure.

Thanks in advance.

Hi, it should be practicable.
Check this post and tell us if you encounter any problem.

@DaveYYY I really appropriate the quick replay.

I read the steps to get an idea, but i got stuck at Environment Variables section

I have already had SDK manager downloaded all the files for me and when I need to recover or prepare a new module and i don’t want to duplicate the files and fill my PC.

What i will do is that i will replace the system.img file (because i have a copy of the original system.img and another copy let say backup_system.img which has all the files i need )

and after running sdk manager to bring-up the module i will run copy backup_system.img and rename it to system.img then run

sudo ./flash.sh -r -k APP jetson-tx2i mmcblk0p1

what i need to know is can’t I just write the name of the system image that i need in the previous command?

So you mean you have two versions of system images, and want to switch between them,
but the need of renaming when flashing makes the whole process complicated?

Exactly, because if i could just change system image name in the command so what i want to achieve is using two commands as following:

1- Flashing the module for first time i will use

sudo ./flash.sh -r -k original_system.img jetson-tx2i mmcblk0p1

2- then after that I want to flash the prepared system image

sudo ./flash.sh -r -k backup_system.img jetson-tx2i mmcblk0p1

Is there a way or a command to help me to achieve that?

Hi, I will check with our internal team to see if it’s possible,
or if this feature could be added in future releases.

I really appreciate it.

I have something in mind i will try to test and let you know if it works.

While i’m searching i found this in the documentation you can find the page here

Use NVIDIA SDK Manager to install Jetson Linux and other JetPack components on your Jetson developer kit. For instructions, see the appropriate Jetson Developer Kit user guide. Alternatively, see the topic Quick Start to flash your Jetson module with the bootloader and file system only, excluding other JetPack components.

So if i went this road is it going to make any conflicts if i tried to install the backup image that i have?
Because as I have mentioned I have already everything prepared and installed on the backup image.

Not pretty sure how does the post address the renaming issue,
could you elaborate it more clearly?
But as long as it’s the official way stated in the document, it should not cause problems.

I really appreciate your help and response, I have adjusted the title to make it more clearer.

But what about Jetpack components is there a way to install them after bringing up the board?

Hi, sorry for misleading you before.
Please check To flash a specific partition.
Use the option -k APP to specify the partition you are flashing into,
and --image <file name> to specify the name of the image file.

@DaveYYY thank you and I really appropriate your help and quick replies.
I will try it and let you know if it works.

@DaveYYY I have tried it with the same arguments, but for some reason it stuck on the startup page.
and if I tried it with backup_system.img it get stuck on NVIDIA logo.

I have tried to understand the commands, but i think there’s something I’m missing
between running this command

sudo ./flash.sh -k APP [--image stock_system.img] jetson-tx2i mmcblk0p1

And simply using sdk manager with the stock OS.

Try to dump the log from serial console when it “gets stuck on NV logo”.

Thanks for the replay,
I will try it and let you know.

@DaveYYY and @DaveYYY I really appropriate your help with my issue.
I just noticed that i was using the wrong system.img

As mentioned in this tutorial

I was suppose to use system.img.raw and rename it to system.img
But instead i was using the generated system.img after cloning.

I’m really thankful for your support.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.