Flashing TK1 (DJI Manifold) - Weird Menu Blink

Last night I was able to flash my TK1 (Manifold) thanks, in great part, due to this forum.

However, when the tk1 boots up into unity (lightdm) and I begin to run apps (like a terminal window), the menu bar of the terminal window appears and then disappears about once a second. There is also other flashing behavior at the top of apps, like firefox. The windows resize slightly when the menus appear. It is like they are toggling between show menu on and show menu off.

Do I need to flash again?

Or is there another solution?



I’m not familiar with “Manifold”, but it almost sounds like an autohide feature not behaving well. Sometimes menu bars are designed to hide unless a mouse is over them, and applications try to resize whenever the hide or show phase changes. If for some reason something was causing an autohide to start and then stop you’d get what you’re describing. Is there any kind of autohide setup possible on the menu bars or desktop?

Manifold is basically a Jetson TK1 that DJI has developed an SDK to work with their Matrice-series drones. It’s I/O configuration is a bit different but as far as I can tell it is a TK1 development board in a box.

I have done some more looking and I am going to try and force the menu bars to only appear at the top of the window which may help but looking for some auto-hide switching mechanism is a good idea.


You might want to install a different WM, Ubuntu’s Compiz compositor has a couple of issues with NVidia drivers, which kind of sounds like what you’re running into.

That is what I ended up doing. Thanks for confirming my suspensions.

Can you please share how did you manage to flash your Manifold? I’ve been following I followed the steps found on this link:

But my flash fails with this issue:

downloading bootloader -- load address: 0x83d88000 entry point: 0x83d88000
download command failed NvError 0x120002
command failure/warning: bootloader download failed (bad data)

Failed flashing ardbeg.

This is:

0x00120002, "packet was nacked"

…it’s a USB error almost always caused by a VM on the host. Is this a native Linux on the PC, or a VM? If VM, can you try with a native install? If not, this may help:

Not VM, I am running Ubuntu16.04 on a dual-boot. I also made sure to use the USB2.0 port and the USB cable that came along with the device. All throughout the flashing, I continuously verify the USB connection through lsusb.

Bus 001 Device 007: ID 0955:7740 NVidia Corp.

Do you get packet NAKed more than once? If you go through a HUB, can you try either direct or through a different HUB? If not through a HUB, try a different port on the host.

I tried different USB ports and cables but also end at the exact same spot.

Host is 16.04
package is Tegra124_Linux_R21.7.0_armhf.tbz2
Direct cable from host to DJI Manifold

*** Flashing target device started. ***
./nvflash  --bct PM375_Hynix_2GB_H5TC4G63AFR_H5TC4G63CFR_RDA_924MHz.cfg --setbct --configfile flash.cfg  --create --bl fastboot.bin --odmdata 0x6009C000 --go
Nvflash 4.13.0000 started
BR_CID: 0x34001001740df2051c00000016038440
rcm version 0X400001
Skipping BoardID read at miniloader level
System Information:
   chip name: unknown
   chip id: 0x40 major: 1 minor: 1
   chip sku: 0x0
   chip uid: 0x00000001740df2051c00000016038440
   macrovision: disabled
   hdcp: disabled
   jtag: disabled
   sbk burned: false
   board id: 0
   warranty fuse: 0
   dk burned: false
   boot device: emmc
   operating mode: 3
   device config strap: 0
   device config fuse: 0
   sdram config strap: 0

RCM communication completed
BCT sent successfully
sending file: tegra124-jetson_tk1-pm375-000-c00-00.dtb
- 59661/59661 bytes sent
tegra124-jetson_tk1-pm375-000-c00-00.dtb sent successfully
odm data: 0x6009c000
downloading bootloader -- load address: 0x83d88000 entry point: 0x83d88000
download command failed NvError 0x120002
command failure/warning: bootloader download failed (bad data)

Failed flashing ardbeg.

I have very few details on the Manifold, but first can we rule out that you are using a VM? VMs have a lot of errors with USB (apparently due to how the USB re-enumerates).

Second, since this is essentially a custom board, did the manufacturer provide any of their own software for flash? Typically the error you saw would not be caused by using the NVIDIA flash software version, but had it succeeded on USB, then it might have failed for other reasons.

Do you have a URL to the manufacturer’s site someone can look at (especially for downloads and other support)?

Trying to flash from bare metal host.

DJI never updated the image after the initial release. I can maybe look for hints by comparing the flash.sh that is released by DJI or by checking their forums for hints, will do that, thanks.

I am interested because of the original statement of this thread:

Unfortunately no info on special steps to be taken.

I checked the DJI forums and the info about the manifold is minimal, so no luck there.

I’d like to be able to see if some updated kernel functionality (squashfs) is available.

It might be an issue that I have an SD card mounted, I found someone with a mounted SD card having a flash issue resolved after removing the SD card during flash.


SD card doesn’t seem to be the culprit. Still not getting much further.

Sometimes having a flash card present during boot can get in the way, but that would depend on the bootloader’s boot device search order. I have no information at all on this board or what instructions they might provide. If they have their own flash software you might start with that…otherwise it is kind of a “black box” where we only know what the SoC is and nothing about what surrounds it.