Flashing TX2 with L4T 28.3 fails with "Cannot Open USB"

I need to use L4T 28.3 on my TX2 for software compatibility reasons

When trying to flash the TX2 with L4T 28.3 on the TX2 DevKit I fail with exit message:

[   2.3213 ] tegrarcm_v2 --boot recovery
[   2.3225 ] Applet version 01.00.0000
[   2.3412 ] 
[   2.3422 ] tegrarcm_v2 --isapplet
[   4.0123 ] 
[   4.0937 ] tegradevflash_v2 --iscpubl
[   4.0946 ] Cannot Open USB

The UART logs are:

[0051.007] E> Waypoint-0.5 ACK pending: 0x8
[0051.011] C> MTS error (2) : dram alias check failure
[0051.016] C> cpu waypoint 0.5 failed
[0051.020] C> ERROR: Highest Layer Module = 0x32, Lowest Layer Module = 0x32,
Aux Info = 0x1, Reason = 0x6

I can flash with L4T 28.4, so it is not an issue with my hardware nor host os setup.

I have tried with L4T versions 28.3.0, 28.3.1, and 28.3.2.

Here are the flashing logs (*.logs files) and the uart console logs (*.minicom files):




And here are the logs from the successful L4T 28.4 install:

Note: if you download these files they might say "cti-orbitty" at the beginning. Ignore that. I tested this on the devkit, but my logging tool automatically appends "cti-orbitty" to each file. This was done on the TX2 Devkit.

For diversity, I also tried flashing on the cti orbitty board but it fails with:

[   2.4133 ] tegrarcm_v2 --boot recovery
[   2.4152 ] Applet version 01.00.0000
[   2.4379 ] 
[   2.4415 ] tegrarcm_v2 --isapplet
[   4.1085 ] 
[   4.1113 ] tegradevflash_v2 --iscpubl
[   4.1121 ] CPU Bootloader is not running on de

Of course, on the Orbitty I can’t get uart, so I don’t have uart logs for “CPU Bootloader is not running on device” failures, only for “Cannot Open USB”

I have also previously reported the downstream issue this causes in Jetpack 3.3.2 and 3.3.1 in these threads:

Please check if this is due to the PCN here.


Yes, that’s likely the cause. How can I get access to a patch so that I can use L4T 28.3?

If full L4T upgrades are not feasible for customers, patches may be provided. Contact your NVIDIA support representative for details.

please move to rel-28.4.

I cannot. What alternatives are there?

Here we only provide for R28.2.1, please find the patch from Linux for Tegra R28.2.1 | NVIDIA Developer
Or please move to newer SW.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.