FlashNVIDIA DRIVE™ Software 9.0 on Pegasus

When try to flash on Pegasus, installation button is disabled.

And host PC is also 16.04 so it should be work(and several month ago it was working), but Now it doesn’t work.

I attached image capture, and “TARGET OPERATING SYSTEM” disabled, and “CONTINUE TO STEP 02” also disabled. I also check after connect to Pegasus, but also same symptom.

And if i select another Target Hardware, it is enabled.


Software Version
NVIDIA DRIVE™ Software 9.0 (Linux)

Target Operating System
Linux

Hardware Platform
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version
other 1.7.3.9053

Host Machine Version
native Ubuntu 16.04

Screenshot from 2022-04-29 13-58-46

Dear @jw31,
Please share output lsusb on host to see if board is detected. I assume you have connected host and target via USB cable on debug port.

Also, may I know what is the current version on DRIVE and why you have not upgrade to DRIVE SW 10.0?

I didn’t check lsusb, but
I remembered that if not connected with target board it was enabled. Please check it.

Next monday I also check lsusb.

after I plug-in to xavier debug port and checked lsusb, it looks like recognize usb.

Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 014: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 001 Device 013: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 001 Device 012: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 001 Device 011: ID 0403:6011 Future Technology Devices International, Ltd FT4232H Quad HS USB-UART/FIFO IC
Bus 001 Device 010: ID 0424:2807 Standard Microsystems Corp.
Bus 001 Device 004: ID 8087:0aaa Intel Corp.
Bus 001 Device 003: ID 5986:211c Acer, Inc
Bus 001 Device 002: ID 1038:1122 SteelSeries ApS
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

DRIVE Software 10.0 is the latest version of DRIVE Software. Please upgrade to it. Thanks.

This is not answer for my question. Please check is it impossible to install 9.0 and provide some solution.

You can try https://developer.nvidia.com/nvidia-sdk-manager-sdkmanager-deb-1.6.0.
But if possible, please share with us why you need to stick with DRIVE Software 9.0. Thanks.

I knew that you encountered some issues with the installation and are working with our colleague.
Our team has made some updates to the installation. Please try it again. Thanks.