FlatSim deployment to Jetson Nano FindModuleSpace() error

Flatsim runs fine with:

bazel run //packages/flatsim/apps:flatsim

but when deploying to Jetson Nano with:

./engine/build/deploy.sh --remote_user -p //packages/flatsim/apps:flatsim-pkg -d jetpack44 -h --run

I get the following error:

Traceback (most recent call last):
File “./packages/flatsim/apps/flatsim”, line 368, in
Main()
File “./packages/flatsim/apps/flatsim”, line 272, in Main
module_space = FindModuleSpace()
File “./packages/flatsim/apps/flatsim”, line 111, in FindModuleSpace
raise AssertionError(‘Cannot find .runfiles directory for %s’ % sys.argv[0])
AssertionError: Cannot find .runfiles directory for ./packages/flatsim/apps/flatsim

It seems the .runfiles directory is not being copied over?

deploying Ping app and stereo_dummy worked fine though

Appreciate any advice.

I am also running into this issue and have confirmed ping and argus camera worked when deployed

@hoa you’ll want to follow the instructions here because it appears this app has some python components to it. I was able to deploy, SSH in to my unit and use the following command to run:

 cd ~/deploy/<username>/flatsim-pkg/
./run packages/flatsim/apps/flatsim.py