FleX Demo Segmentation Faults on AWS EC2 GPU Instances

Hi,

I am having issues running the FleX demo (v0.9.0) on AWS EC2 GPU machines (specifically Ubuntu 14.04 on g2.2xlarge). To set up the machine, I followed the instructions at https://github.com/BVLC/caffe/wiki/Install-Caffe-on-EC2-from-scratch-(Ubuntu,-CUDA-7,-cuDNN) up to “Installing cuDNN” and then used apt-get to fill in the remaining dependencies. I’ve also tried setting up the machine with the 352.79 version of the nvidia driver, as opposed to the 346.46 mentioned in those instructions.

I am able to successfully recompile the demo for both release and demo targets, but when I run the demo, I get a segfault at demo/shaders.cpp:739. Oddly enough, when I rerun that line in gdb, it seems to work just fine. When I comment out the creation of the shaders, I get another segfault in Mesh::GetBounds which gets called on init; when I comment out the initialize, there’s another segfault in the glut mainloop; when I comment that out, there’s nothing to run in the demo.

Has anyone had success running the FleX demo on aws gpu instances?

Hi,

I have encountered the same issue, though not on EC2 but some of our local servers.

Is there any update on this? Thanks.