Flicker issues in TTY, Latency issues in Xorg

So, for some reason I’m getting this issues with NVIDIA drivers. I can confirm this is NVIDIA-specific, since with nouveau this issues disappear(well, the flicker in TTY. With nouveau I can’t even launch Xorg due to it finding no screens). In TTY, every second or so a black frame appears, which eventually makes my head hurt a lot. In i3-gaps(or Xorg in general), the mouse is very very laggy, and if I press a key, more often than not a key is interpreted as double.

I’ve tried everything from https://www.reddit.com/r/archlinux/comments/b4a8aa/issue_with_nvidia_graphics_driver/ here and https://www.reddit.com/r/archlinux/comments/be0lrx/here_we_go_againnvidia_issues/ here.

My specs are:

Arch Linux
Linux 5.0.7
Ryzen 3 1200
Geforce GTX 1060 6Gb
8gb Ram
nvidia-bug-report.log.gz (1.1 MB)

Sounds like some irq problem.
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

It should be on main post now.

Nothing unusual for now. Please run ‘top’ in a terminal window in X and check if any process is using a high amount of cpu while moving the mouse.

The highest process is actually nvidia-modeset, with 24-30% of the CPU, and sometimes Xorg, with 24%.

Ok, that’s odd:

Link Width
                Max                 : 16x
                Current             : 2x

What kind of mainboard is this? Tried a different slot if possible?

Well, what you said to me motivated me to look from behind my PC, and what do you know, I found my HDMI plug slightly out. I feel so ashamed for this…

But anyway, thanks for everything! Looks like sometimes life problems are more simple than they look.

EDIT: I checked and the link is still being detected via nvidia-smi as 2x. I verified and the GPU is on the 16x slot. Hmm…

LOL. This explains why nvidia-modeset was struggling. Nevertheless you should take a look if the reduced pcie width was also caused by this. At idle (P8) it should be at x1 but under load (P0) it should hit x16. Use
nvidia-smi -q
to display the values.