Flickering at the top of the screen

If I activate the maximum performance mode, my GPU (an RTX 2080) consumes 40 watts. As a result, its temp gradually rises to 60 degrees and then the fan activates until the temperature drops to 47 degrees and so on.

That’s why I prefer to put the screen at 100 hz. I can stick with adaptive mode and the card only draws 12-13 watts. Moreover, the clock frequencies are at their minimum.

It is likely that your GPU is better cooled than mine, so if you don’t have excessive heat, you can stay in this mode.

Reinstalling 525.116.04 is clearly the best solution until the problem is fixed. However, the kernel will evolve and new versions will be released. There will come a time when 525s will no longer build.

Additionally, 535 fixes a freezing issue with AC Valhalla that occurs when GPU usage hits 90%. Going back is not an option for me unfortunately.

I also hope that this issue will be resolved soon. But knowing that it was first declared with the release of the 530 and if it is true that it really only concerns cards with the Turing architecture, I fear that it will take longer to be corrected.

Fingers crossed.

Thank you for the command lines to set PowerMizerMode. I was using nvidia-settings GUI before you mention it.

By default I also have the fans activating over 60 degrees, when it happens they start full speed so it isn’t pleasant.

If it was only when playing a game would have been bearable, but it does it even using the browser (even with adaptive mode, surely it is worse as you say with performance mode).
So sometime ago I have decided to use nfancurve to set my fan curve: I have a minimum fan speed of 25% (under 60 degrees), which means ~850 rpm and 45 degrees celsius (pretty much constant using desktop).

In any case let’s hope they fix this, because it is not good at all!

I have installed the new “Production Branch Version” 535.54.03 driver, it has this issue.
How can a production branch version have a glaring issue like this?

Right now every downloadable 5xx driver is affected by this issue, not bad.

This issue has existed since version 530 was released.
I reread the threads on this forum talking about the flickering problem. I also reread those from other forums (manjaro, endeavourOS). Absolutely everyone having this problem has a card whose hardware architecture is Turing (GTX 1660, RTX 2060, 2070s, 2080, 2080s and 2080TI).

The first topic was created at the end of March. We are in June and it is still there with the 535 betas. Unfortunately, there was little chance that this would be resolved for the release of the 535 stable.

If a version fixing this problem should be released, I don’t think it will be before the next major release; maybe 540. But we’ll probably have to wait until September for that. Turing is an architecture equipping GPUs released in September 2018. 5 years is a decade in computing. We’ve the RTX 3000s and now the RTX 4000s. Bugs affecting the RTX 2000s may not be the priority.

In the meantime, we have to use workarounds to limit flickering (as mentioned above) or revert to the 525 drivers. However, if gaming is a priority, we’ll have to do without the new vulkan extensions and performance improvements.

Yes, I have read your previous messages and yes, also in my experience it is since driver 530 that we have this issue… but my point of view is pretty different because we are talking about:

  • Normal video output usage being bothersome without workarounds;
  • An architecture (Turing) which is currently supported and not a legacy one (the years don’t matter);
  • We are talking about the production branch (which should be the smoothest in this regard).

This is not acceptable at all in my opinion.

1 Like

Wanted to confirm that I’m suddenly seeing a similar but worse issue – the whole screen flickers completely to black and back each time this occurs. These interruptions last roughly a second.

I am on Arch Linux, which recently updated to 535.54.03. Issue started right after update. I’m using RTX 2070 Super and nvidia-drm.modeset=1. My resolution is 3840x2160 @ 144 Hz.

I can confirm that the PowerMizer workaround listed here does work, but my GPU power draw more than doubles from around 25W to 55W. Not ideal at all. I can reproduce the issue in a matter of minutes when switching back to the adaptive setting.

Attaching my bug report just in case.

nvidia-bug-report.log.gz (352.5 KB)

Edit: Downgrading to 530.41.03 makes the issue completely disappear for me.

Found the original thread about this issue here: Very short black flickering (flashes) with nvidia 2080Ti since nvidia 530.41.03 driver.

1 Like

Alas, I spoke too soon. It seems these can occur even on the highest power level, although the frequency seems to drop by quite a bit.

1 Like

The power switching (and a few other things) were speculated about with the 530 drivers as everyone frantically tried to figure out wtf was going on but it was all bumkis. If it worked it was either coincidental or just decreased the frequency making it seem fixed until BLAM, there it is.

Fingers crossed they fix it this time and perhaps fix the search on here since this post is a few days before mine but didn’t show when I searched before reposting about the issue returning for the 535’s.

Message to avoid getting the thread closed after two weeks from last response.

I don’t notice anything when playing games, everything is ok on the top screen as well. But the desktop (KDE NEON 22.04) does not run so smart anymore. There it did not before.

Driver directly from the Ubuntu Repoitory 535.54.03
Nvidia GTX 4090

I am also experiencing a steady rate of intermittent flickering once every 15-30 seconds using proprietary Nvidia drivers.

Nvidia Driver Version: 535.54.03

GPU: GeForce GTX 1650

Screen Resolution: 2560x1440 @ 144Hz refresh rate

OS: Arch Linux Kernel 6.1.37-1-lts

Desktop: Gnome 44.2 & GDM 44.1 with X11 (X Server Windowing System)

This wasn’t an issue prior to upgrading to 535.54.03. Hope they provide a fix soon.

1 Like

Hello, I have the same issue!

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.2 LTS
Release: 22.04
Codename: jammy

libnvidia-cfg1-535:amd64 535.54.03-0ubuntu0.22.04.1
libnvidia-common-535 535.54.03-0ubuntu0.22.04.1
libnvidia-compute-535:amd64 535.54.03-0ubuntu0.22.04.1
libnvidia-compute-535:i386 535.54.03-0ubuntu0.22.04.1
libnvidia-decode-535:amd64 535.54.03-0ubuntu0.22.04.1
libnvidia-decode-535:i386 535.54.03-0ubuntu0.22.04.1
libnvidia-encode-535:amd64 535.54.03-0ubuntu0.22.04.1
libnvidia-encode-535:i386 535.54.03-0ubuntu0.22.04.1
libnvidia-extra-535:amd64 535.54.03-0ubuntu0.22.04.1
libnvidia-fbc1-535:amd64 535.54.03-0ubuntu0.22.04.1
libnvidia-fbc1-535:i386 535.54.03-0ubuntu0.22.04.1
libnvidia-gl-535:amd64 535.54.03-0ubuntu0.22.04.1
libnvidia-gl-535:i386 535.54.03-0ubuntu0.22.04.1
nvidia-compute-utils-535 535.54.03-0ubuntu0.22.04.1
nvidia-dkms-535 535.54.03-0ubuntu0.22.04.1
nvidia-driver-535 535.54.03-0ubuntu0.22.04.1
nvidia-firmware-535-535.54.03 535.54.03-0ubuntu0.22.04.1
nvidia-kernel-common-535 535.54.03-0ubuntu0.22.04.1
nvidia-kernel-source-535 535.54.03-0ubuntu0.22.04.1
nvidia-settings 510.47.03-0ubuntu1
nvidia-utils-535 535.54.03-0ubuntu0.22.04.1
screen-resolution-extra 0.18.2
xserver-xorg-video-nvidia-535 535.54.03-0ubuntu0.22.04.1

1 Like

Hi All,
I have seen flickering of entire screen on my setup locally and we are actively debugging the issue.
Bug 4164132 has been also raised for the same.


Hello guys, i was one of the guys who created a Topic about this Black Flickering few month ago and even with the workaround with nvidia_drm.modeset=1 that could solve the issue for a while… the bug comes back with 535.54.03… atleast its not this annoying as few month ago but it still a pain to see it again :(

I also removed today nvidia_drm.modeset=1 from grub but no changes.

Nvidia Driver Version: 535.54.03

GPU: GeForce GTX 2080Ti

Screen Resolution: 2560x1440 @ 144Hz

OS: Manjaro Linux Kernel 6.1.38-1-lts

Desktop: KDE with X11

Can we PLEASE FOR THE LOVE OF GOD get a fix for this? I know it only affects Turing GPUs and it’s not a high priority but this is something that was working just fine and now it’s completely broken! This should have been fixed straight away! My distro doesn’t allow me to downgrade to older drivers and I’m at my wits end here.

1 Like

FOR THE LOVE OF THE (non-existing) GOD I’ve just downgraded drivers to version 525, what I recommend to all of you.

But, of course, it’s weird, that there is no reaction from NVIDIA staff, and no fixes nor for v530 neither v535.

Update: My bad, I see the reaction above. I hope they’ll fix it for v540. Let’s wait (and whine if it’ll not be fixed).

1 Like

Luckily with the power states set to performance mode I have this kind of flickers very rarely… I can bear it but I don’t want to imagine using my PC without this setting applied.

I think that to certain people a constant flicker like this one could even cause headaches.

Furthermore as said there were already reports months prior to my post here, pointing to some issue in the drivers.
The response from NVIDIA acknowledging this issue on daily PC usage, starting to debug it just one week ago is really bad from a market leader: they waited for every possible user with a Turing card and an high refresh monitor to have this issue before moving.

This slow response caused the drivers to get pushed as stable on many repositories, without users being able to downgrade: NVIDIA’s site itself doesn’t allow to download 525 drivers anymore! and even when this will be fixed it will take some time to have it as a stable release on repositories.

I hope this gets fixed soon and that it is just a one off: issues like this can’t be managed like it’s happening here.

Even if NVIDIA site doesn’t allow you to download old versions of drivers, I remind you, that most of popular distros (like Arch) allow you to use archives of packages.

1 Like

Sure thing, searching around you can find the drivers in the archives and using the terminal you can install them, hopefully without troubles (and troubles are around the corner with this stuff).
The point is that a driver with issues like this one shouldn’t be pushed as stable but right now it is.

Done the same here from a week. This time it is the best way, also so that some games no longer work.