Flow USD extension in Omniverse Kit is not installing

Hey guys, i just installed Omniverse to try out Omni flow. But whenever i try to enable the extension, i get this error.

was hoping someone could help me out here.

Thanks in advance!

Hello, the log indicates an old version of Kit is being used.
In the OV launcher, I would recommend installing a newer Create instead. The newer Create will come with Flow enabled by default.