fluidsGL results in error


I just installed the CUDA SDK and Toolkit on my Debian system.
Running most examples seems to end successfully but when trying fluidsGL I get this:
freeglut ERROR: Function called without first calling ‘glutInit’.

anyone know the remedy ?

thanks in advance

Try to add glutInit(&argc, argv) after the glutInitWindowSize call.

This is a known bug in the 0.8.1 SDK. This occurs with freeglut, but it is a bug in general. Other glut libs just don’t check…

The same bug is in the boxFilter demo.



Theres another problem with fluids for me, sometimes running it is fine, sometimes it results in:

cufft: ERROR: execute.cu, line 29
cufft: ERROR: cufft.cu, line 121
cufft: ERROR: execute.cu, line 306

being printed over and over, and sometimes it totaly freezes the machine. Is this something i should worry about ?

Yeah you should. The demo always worked fine for me.


Thank you, do you have any tips on how I should diagnose this further, I have tried with make dbg=1, then it gives some more information in the cases where it fail (unspecified error, or something like that, im not at the machine now)

There are a lot of possible causes … :(
Are you running on the required RH release, 97.51 driver, 32bit Linux kernel, …
What do you see in /var/log/messages
Check /var/log/xorg.log
Does the machine freeze when playing a game? (power supply inadequate?)

For the record, I am running openSuSE 10.2: default kernel 2.6.18, glibc 2.5, NVIDIA 97.51 driver, 8800GTX


The driver is 97.51. i dont run any games on the computer so i dont know about that.

the powersuply is 300W, i cant check the logs right now but i will when i get home.

thanks for the reply !

300W sounds a bit weak, but that is only the intake. Depending on the efficiency of the power supply, check that it can actually output the required 30 Ampere (GTX) or 26 Ampere (GTS) on the 12 Volt rail (and has something left for the processor). Also check that you connected both power connectors (it does work with one, but not at full speed).


Now I have tried this graphics card
on linux, windows, 2 different computers and the same result in each case,
fluidsGL run correctly in about 50% of the tries.
Does it sound like i have gotten a faulty card ?

thank you and have a nice day

Did you check the power consumption I outlined above?


Yes the power should be ok now, I uppgraded to a fatter PSU and the problem remains


I have the same problem here, here is my config:

Athlon64 4000+

2 gig

evga 8800 GTS 640

My os : Ubuntu 7.04 32 bits

My drivers: 1.0-9751

I don’t think this is related to the PSU. I have a 450 W (25 A @ 12 V). On windows, I can run FEAR (max quality @ 1680x1050) for many hours without a glitch. On linux I can’t say for sure that the driver is OK … I don’t know any valuable benchmark.


Humm… it’s weird. When I activate compiz (GUI 3d effect) … I no longer have the problem…

I’m seeing this also. fluidsGL fails with the messages:

cufft: ERROR: cufft.cu, line 29
cufft: ERROR: cufft.cu, line 121
cufft: ERROR: cufft.cu, line 306

which repeats over and over.

System is Fedora Core 6, EVGA 8800 GTS 640Mb, 97.51 drivers.

I’ve run the fluidsGL demo on the Windows side and it works fine, so I don’t think its hardware related

I’ve enabled compiz, but it doesn’t seem to fix anything…

Edgardz can I see your xorg.conf?

Any suggestions?


Well that’s weird, I recompiled and now its working with no errors… I feel like I’m living in bizarro world…