<font style=

Clang dependency install snippet from ./Setup.sh:

Register the engine installation…
Refusing to run with the root privileges.
Installing a bundled clang toolchain
~/UnrealEngine-IsaacSim_1.2/Engine ~/UnrealEngine-IsaacSim_1.2/Engine/Build/BatchFiles/Linux
Toolchain already installed skipping.

Target arch set to: x86_64-unknown-linux-gnu
Building ThirdParty libraries

Error after make && make IsaacSimProjectEditor:

Setting up Mono
Building CrashReportClient…
Creating makefile for CrashReportClient (no existing makefile)
Performing full C++ include scan (no include cache file)
ERROR: System.ComponentModel.Win32Exception: ApplicationName=’/home/kfr/UnrealEngine-
IsaacSim_1.2/Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux/Linux_x64/v11_clang-5.0.0-
centos7/x86_64-unknown-linux-gnu/bin/clang++’, CommandLine=’ --version’, CurrentDirectory=’’,
Native error= Cannot find the specified file

I can’t solve this problem. I hope so.

Hi Jamesd5ou7

Are you running this as a root? you shouldn’t run as a root (sudo).

Hope this helps
Liila

I didn’t run as root, but I got the same result.

I installed clang manually at the location it prompted, but it didn’t work.

What is your system that you are running this on?

Thank you for your reply.

This error was caused by my negligence. In fact, I ran it as root once after I made an error at runtime.

I noticed that clang was installed in the system, and after I deleted it, I rerun. / Setup. SH and the error disappeared.

I’m sorry about that!

I am glad you got it working :)
Liila