For Jetson tx1, install jetpack 2.3 and jetpack 3.0 both failed.

Hi,

  1. Run JetPack-L4T-2.3-linux-x64.run

  2. In the “Jetpack L4T Component Manager” window, everything is empty.
    –>But in my browser I can open http://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/json/linux-x64/manifest.json

  3. I check the JetPack.log from _installer, the error info is as follows:

07-24 18:18:35.8 W: Host not found: www.google-analytics.com
07-24 18:18:35.8 E: fopen failed, errno = 2

How can I jump this error?

And I tried Jetpack3.0 too. The same issue happened.

I tried to install jetpack on other host linux machine, still the same result.

I am wondering if this command works for you on the PC host running JetPack:

host google-analytics.com
# If this works, then:
ping google-analytics.com

If not, then there is a route issue in the network setup.

Hi linuxdev,

In my opinion, the W in this log “07-24 18:18:35.8 W: Host not found: www.google-analytics.com” means a warning, not an error.

And in china, we can’t open any google website normally. And I searched other people in China who installed successfully, no one mentioned about this issue.

This morning I get the latest jetpack 3.1 and the error content in JetPack.log is :

07-26 02:07:22.9 W: Host not found: www.google-analytics.com
07-26 02:07:22.9 W: Space info is invalid: /home/jetpack3.1/
07-26 02:07:22.9 E: fopen failed with file local.db, errno = 2

What is local.db?

Yafei
Thanks.

I’m not sure what that is, but I suspect it means the local .deb repository placed in “/var” was missing (and it would be missing if a download failed since JetPack downloads this and then places a copy on the Jetson…once it is in place the Jetson does not actually require networking to browse CUDA-related packages).

Hi,

I tried many ways to install the Jetpack, all failed by “Jetpack L4T Component Manager” is always empty.

I found a way mentioned in this topic:

https://devtalk.nvidia.com/default/topic/899184/jetson-tx1/couldn-t-install-jetpack-2-0-on-tx1/post/4783925/#4783925

The problem is the content mentioned in this topic is all for Jetpack2.0.

I want to know if there is the file(http://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/001/json/jetpack-l4t-devzone.json ) for Jetpack3.0 or 3.1?

Thanks.

I was able to download “jetpack-l4t-devzone.json”…but perhaps it is an address within the file which is failing you. If you need the file itself and cannot download, I can verify the file is there and downloadable…this of course might change depending on what network you are using.

Hi

The weird thing is I can download the file through my browser.
After I download this file put it to the install path and change its name to repository.json, “Jetpack L4T Component Manager” window can diaplay the packages, not empty like before.

But this file is for jetpack2.0. I need this file for jetpack3.0 or 3.1.

Do you know how to download this file for jetpack3.0 or 3.1?

Thanks.

Hi yafei,

You can download the latest JetPack3.1 release build from below link:
https://developer.nvidia.com/embedded/dlc/jetpack-l4t-3_1

And following below steps to install:
http://docs.nvidia.com/jetpack-l4t/3.1/index.html#developertools/mobile/jetpack/l4t/3.1/jetpack_l4t_install.htm

Thanks.

Just speculating, perhaps the file was renamed at the server when the new JetPack 3.1 came out. The old file name should still be there, but perhaps is not.

EDIT: I see a note that the JetPack 3 issue is now fixed.

Hi

Now I am sure it is my network issue.

I think I can resolve this issue when my network is OK.

Thanks for all your help.