Forceware 169.09 stops all CUDA samples The 11/13 beta driver release

I installed the Forceware 169.09 beta release of the new drivers for Win XP. But doing this prevents me from running any samples that come with the CUDA SDK.

The examples do not run stating “unspecified driver error”.

For the simpleGL the error is -

Line 138 is : CUT_DEVICE_INIT();

All samples give the same error at exactly the same instruction - initialization.

I tried installing the drivers in the following two ways -

  1. Running the exe

  2. Using the steps in the readme.txt (Updating the driver through the device manager)

Rolling the drivers back to the 163.71 Forceware lets me run the samples without any problems.

Another thing I noticed was that when I installed the 163.71, it created separate folders for WinXP and Win2k drivers in the NVIDIA folder. But the 169.09 only created a Win2k folder with all its files inside that. The readme in that folder does say that this driver is for Win 2k/XP- home/professional and also for Win2k3 Server. I double checked that the setup file I downloaded was for WinXP. At least the file name says -

169.09_forceware_winxp_32bit_english_beta.exe

I also tried all the monitor configurations - single monitor, horizontal span, dual view. None of them work.

And yes, I did restart my machine - several times.

Did I miss something? Any help/comments appreciated.

Did you install the 1.1 toolkit?

I did not install the toolkit. Where can I get it? I am not a registered user yet [I have requested it, so am in queue.]

But I could get the beta driver when I searched around on the site, but no the toolkit. :ermm:
Is there a way I can get it?
I would appreciate if someone gives me a link to it.

Thanks.

I got the sdk 1.1 and toolkit 1.1 and installed both. Now when I run the samples I get a run-time error -

I am removing all the previous installs I have related to the CUDA (toolkit, sdk and driver) and installing everything afresh. Hopefully that will work.

Thats done it.

So you need 3 things -

  1. the dirver
  2. the toolkit; and
  3. the SDK.

This is how I got them working:
Remove all the earlier versions. (Control panel > Add Remove).
Install all 3 in that order above.
Enjoy

BTW - Cool new samples in the SDK 1.1!

Hey not all samples run though!
Till now most samples that do not use any graphics interops worked smoothly. But here is a list of OpenGL samples that did not work and instead gave an error about some ‘entry point not found _isInteropSupported@0 in cutil32.dll’
SimpleGL, fluidsGL, postProcessGL.

But nBody sample which also uses opnGL seems to work fine.

With D3D, simpleD3d works fine. But fluidsD3D after starting up crashes the system.

I did not check what GL the particles demo uses. But it started and worked great the first time. But now it crashes the system the same way fluidsD3D does.

Maybe its because these were not overwritten by the new SDK? I am now manually cleaning up the entire SDK folder (after uninstalling it through the control panel) and re-installing the SDK. Will post what happens after that.

sweet… :thumbup: that was the problem. So when uninstalling the SDK, make sure you go in manually and delete all the earlier projects.

[ IF YOU CREATED NEW PROJECTS IN THAT FOLDER, DO NOT FORGET TO SAVE THEM SOME PLACE ELSE!! ]