Fortran 6.6

I have typed the lines below in fortran:

Write(,)‘Valor de X’
read(,)X

Write(,)‘Valor de Y’
read(,)Y

Z=X+Y


Write(,)‘Valor de Z=’,Z

Stop

End

After that I compile and run the program, but when I build the program *.exe. It created the following lines:

--------------------Configuration: Text1 - Win32 Debug--------------------
Linking…
LINK : fatal error LNK1104: cannot open file “Debug/Text1.exe”
Error executing link.exe.

Text1.exe - 1 error(s), 0 warning(s)

Somebody would help me with that error?

Hi AluizioP,

This looks like a permission error. Can you double check that you have read/write permissions in the “Debug” directory? If “Text1.exe” exists, make sure you have permissions to overwrite it. Finally make sure Text1.exe isn’t running.

Hope this helps,
Mat

The “Text1.exe” exists, but it does’t run until the end of the program.
I think that the error is related to the Fortran. Maybe it needs some update. Do you know about that?

Thanks for your help!

Hi AluizioP,

The “Text1.exe” exists, but it does’t run until the end of the program.

The above error occurs at link time and indicates that the linker can’t create the new binary. If “Text1.exe” already exists, it would indicate that you don’t have permissions to overwrite the binary.

Are you getting a different error?

I tried your program it ran correctly for me so I don’t think the issue is your program or the compiler.

  • Mat

The problem was solved!
I installed Fortran 4.0 and it showed that the problem was about the path of the archive. Fortran doesn’t accept spaces for the name of the directory.
Thanks a lot for your attention.

Sorry! The problem was not solved.

I made a video with the step by step that I did. How can I put it available?

Thanks,

Aluizio.

Ok!

Now the problem was solved!

The antivirus was restricting the Fortran.

Thanks a lot!