Fortran - disallow implicit declaration

Hi forums,
Is there a way to disallow implicit variable declaration in pgfortan? Something like -fimplicit-none in gfortran.

Hi Levi,

There’s no compiler flag since implicit typing can have more specifications than just none. You will need to explicitly set this in your code using the “IMPLICIT NONE” statement.

  • Mat

Thanks, Mat.

I find that -Mdclchk does what I need from the command line as well.