Forums seems broken

Maybe it’s just me, but recently I’ve been having trouble here (and only here). When opening the forum the site is “frozen” in a way that I can’t scroll, click or otherwise interact with it.

Reloading a few times eventually fixes it, in that tab.

Chrome on windows (105.0.5195.127 (Official Build) (64-bit))

Hi, I am not hearing any reports about this from others at the moment. I have been active on the forums all morning with no issues. Have you tried rebooting your system?


I’m on the same Chrome build and haven’t seen this either. @tjaenichen one thing you could try is using a different Chrome profile, sometimes this kind of thing happens due to cache or cookies or local storage. If switching profiles fixes it, you could clear out any stored data for


1 Like

Strange, ok. Thanks for checking! I’ve had this issue for a while, tried turning off adblock etc. as well.

It might not be on your end, this web stuff is complex these days. ;) You can open chrome devtools and watch the list of requests when loading the page. Sometimes you can catch one of the requests getting stuck and note the URL. Or if that’s not it and you’re really adventurous, break in the Chrome debugger while scrolling is stuck; the file or resource name where it stops might be a clue, even though the code will likely be unreadable. If you find something wedged that’s out of your control, we’d love to hear about it so we can alert the right people.


I’m having the same problem.
When using Chrome on Ubuntu 22.04, this Nvidia forums sight will not scroll.
However, it works fine when using Firefox.

Simply deactivate some of the Chrome extensions (or all for test); If still not working reset your Chrome settings to default and restart it (then allthe extensions are reset also). I had this a while ago and a few (auto-updated?!) Chrome extensions suddenly caused this freezing here in this forum.