FPS issue with Jetson Xavier NX for deep learning

Hi, I have been working on live traffic sign detection using a usb camera. However, it’s happening at 2-3 FPS but the camera itself can go up to 60 FPS. Running on my own computer has 30+ fps in the same environment.

I tried decreasing my image size to hopefully increase the FPS but failed. I also noticed that the CPU usage is at its maximum but not the GPU.

Does anyone have any insight and/or questions to help me solve this?
Appreciate it a lot. Thanks!

Suppose it could be block by the memory copy.
Check your pipeline to avoid any memory copy to confirm it.

Thanks

I found out that the xavier is not running with opencv CUDA. Then, I tried following the instructions in this youtube video : https://youtu.be/BCNnqTFi-Gs?si=fsiEvOrEcatoxVZK

The FPS increased to 4-5 fps whereas they can go up to 40. Is there any other solutions for this? Thank you very much.

You can reference to the MMAPI sample like 12_v4l2_camera_cuda/18_v4l2_camera_cuda_rgb to avoid memory copy to hurt the performace.

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.