Frame generation does not work

Hello, I have an RTX4090, and the frame rate remains the same regardless of whether I have FG enabled or not. I have seen some errors in the log, and I have the latest GPU driver and WIN11 system.


It remains at 180 frames.

Hi @a462912172 and welcome to the NVIDIA developer forums!

I do not think that anything is wrong here, the error message should not be fatal as long as it does not repeat.

As for the framerate, check out the last section in the “DLSS_Frame_Generation_Quick_Start_Guide.pdf” which is part of the plugin download. The “Stats” paragraph right before “Tips and Best Practices” explains this:

The engine is not directly aware of additional frames generated by frame generation, so built-in frame rate and frame time metrics may be missing information. The “DLSSG” stat group provides frame rate stats taking into account the additional frames.

So your FPS in game shows as 181 while your screenshot shows the DLSS Frame Stats correctly at roughly double the rate. You can also enable the GeForce Experience overlay with ALT+R to see the actual FPS going out from the GPU.

The only surprising thing is that the first screenshot claims that FG is off, but also shows the same stats as the second one. I just tried to somehow replicate that behaviour, but I can’t. It would be interesting to see how you arrived at that setting.

I also highly recommend reading the “Tips and Best Practices” section in the doc I mentioned, there are some valuable comments on performance expectations.

I hope that helps.

Due to my changing the loading of the StreamlineCore module to PreDefault, I think it would be better to change the StreamlineBlueprint module to PreDefault by default, so that there will be no blueprint reference errors in my project.

Thank you very much!

{
“Name”: “StreamlineCore”,
“Type”: “Runtime”,
“LoadingPhase”: “PostEngineInit”,
“PlatformAllowList”: [
“Win64”
]
},
{
“Name”: “StreamlineBlueprint”,
“Type”: “Runtime”,
“LoadingPhase”: “PreDefault”
},

1 Like