Frame_meta->ntp_timestamp returns 0

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU): GeForce GTX 1650 Ti Mobile **
• DeepStream Version: DeepStream 5.0
• JetPack Version (valid for Jetson only)
• TensorRT Version: tensorrt 21.02
• NVIDIA GPU Driver Version (valid for GPU only): 515.86.01
• Issue Type( questions, new requirements, bugs): bugs
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

I am trying to get timestamp from RTCP Sender Report of RTSP stream.
I am following instructions described in NTP Timestamp in DeepStream — DeepStream 6.2 Release documentation.

Setted attach-sys-ts-as-ntp config parameter to 0 in the [streammux] group
Made sure, that RTSP source sends RTCP sends reports

However, ntp_timestamp returns 0 (NvDsFrameMeta *frame_meta; frame_meta->ntp_timestamp)

When attach-sys-ts-as-ntp is set to 1, I receive the NTP timestamp of systems, where DeepStream is running
Also I am getting the following warnings:
(gst-plugin-scanner:7): GStreamer-WARNING **: 14:32:55.029: Failed to load plugin ‘/usr/lib/x86_64-linux-gnu/gstreamer-1.0/deepstream/’: cannot open shared object file: No such file or directory

(deepstream-app:1): GLib-GObject-WARNING **: 14:32:55.159: value “0” of type ‘guint’ is invalid or out of range for property ‘gie-id-to-blur’ of type ‘guint’

(deepstream-app:1): GLib-GObject-WARNING **: 14:32:55.171: value “((GstNvInferProcessModeType) 0)” of type ‘GstNvInferProcessModeType’ is invalid or out of range for property ‘process-mode’ of type ‘GstNvInferProcessModeType’

(deepstream-app:1): GLib-GObject-CRITICAL **: 14:33:29.487: g_object_get: assertion ‘G_IS_OBJECT (object)’ failed

It seems that some dependencies of nviferserver plugin are not installed correctly. Could you install the Deepstream 6.2 cause the 5.0 is too old? You can refer to the link below to install the latest version:

Thanks for the answer,

However problem was, that RTCP Sender Report was disabled in camera. After enabling RTCP in camera, DeepStream now returns timestamp from camera.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.