Framerate capped at 30FPS (Jetson TX2)


I have a Jetson TX2 Dev Kit with L4T 28.1 installed. When I’m running the CUDA examples and or my own program I only reach a framerate of 30 FPS.
I can see that the CUDA examples are starting higer then the 30FPS but they are capped within the second to a stable 30 FPS.

I tried to adjust the vsync with the following command; “export __GL_SYNC_TO_VBLANK=0/1” to enable disble vsync but without any result.

I tried the ./ script to increase performance but also no result. And even when I’m using the “nvpmodel -m” profiles I still have the same issue.

It looks like the fps is somewhere capped at 30 FPS.

Does anyone every experienced this?

Thanks in advance,


So ok quick update. When I do the “export __GL_SYNC_TO_VBLANK=0/1” and then start the cuda example from terminal it does work! I then have like 500fps when vsynjc is disabled or 30 fps when vsync is enabled.
Only when I start the cuda examples by double clicking them they are always running in 30 fps.

Still any idea someone?

Hi tangotouch,

There are two vsync in your case. One is from glxswapbuffers and another one from display controller.

If you don’t care the tearing problem, you could turn both off.

  1. export __GL_SYNC_TO_VBLANK=0/1
  2. sudo echo 1 > /sys/module/window/parameters/no_vsync

As for the clicking problem, I think it is because your env variable does not have __GL_SYNC_TO_VBLANK=0/1. Please try to add it to env path.