free bsd compiler error

hi experts, pardon me for this unprofessional question,

i just want to install connectx3 on my pfsense machine which using freebsd 10.3,

i have follow the manual instruction attached on the driver download page i have the .tar.gz driver downloaded to my machine and i’ve extracted it, and i when i try to do a ‘make’ command as the instruction on manual book and suddenly came to this error message.


[2.3.2-RELEASE][admin@firewall.rsudsidoarjo.com mailto:admin@firewall.rsudsidoarjo.com ]/media/freebsd-fbsd_ofed_2_1_6/modules/mlx4: make -m $HEAD/share/mk SYSDIR=$HEAD/sys clean cleandepend

HEAD: Undefined variable.

i think maybe because im not using the root user but when i go after i use ‘su’ command, the error going to be like this :

make -m $HEAD/share/mk SYSDIR=$HEAD/sys clean cleandepend

make: “/usr/share/mk/bsd.compiler.mk” line 39: Unable to determine compiler type for cc. Consider setting COMPILER_TYPE.

i have installed gcc maybe my machine didnt have the compiler which mellanox driver needs. Refer to the bottom post on a Q/A forum answer :

chyves install failing · Issue #4 · chyves/chyves · GitHub https://github.com/chyves/chyves/issues/4

but didnt help anything.

any help would be very useful for me !

regards,

swab

thanks

Hi Swab,

You can manually create it.

Regards,

Viki

Hi Swab,

Make sure that /etc/src.conf and /etc/make.conf files are modified to support cc.

It should include something like that:

WITH_CLANG_EXTRAS=YES

CC=clang

CXX=clang++

CPP=clang-cpp

Regards,

Viki

thanks a lot for your kind answer Viki, i really appreciate that !

finally there’s seems a solution to my problem,

but when i try to find src.conf in my /etc …i found nothing, i mean there’s no src.conf so does make.conf.

i think that was a problem caused to the version of my pfsense/bsd machine which didnt same with the driver version from mellanox,

theni reinstall with pfsense 2.2.6 which using freebsd 10.1 … but it was the same, i found nothing in /etc.

theni reinstall pure freebsd, but it was still the same i found there’s no make / src**.** conf file.

doi need to install something to get that file ?

pardon me and …

thanks,

regards,

swab