FreePGI and Xcode 3.2.6

Hi,

Trying to activate FreePGI in SnowLeopard 10.6.8 with abosve Xcode, I get
the following return :
“sudo xcodebuild -license
Password:
unknown option: -license
Usage: xcodebuild [-project ] [-activetarget] [-alltargets] [-target ]… [-parallelizeTargets] [-activeconfiguration] [-configuration ] [-sdk |] [-xcconfig ] [=]… []…
xcodebuild [-version [-sdk [|] [] ]
xcodebuild [-showsdks]
xcodebuild [-find -sdk |]
xcodebuild [-list]”

Any advice or solution welcomed.

Regards,

lricard

Hi Louis,

My guess is that you have an older Xcode. The command “sudo xcodebuild -license” is for newer version, not sure which version it started to have that option.

You can agree to Xcode license by opening up Xcode and the license agreement page should pop up if you have not agreed to that already.

Your Xcode could be in either one of those 2 locations:

  1. Applications->Xcode
  2. Developer->Applications->Xcode

Let us know if that works.
Hongyon

As mentioned in my initial post, I have Xcode 3.2.6 installed on my MacBook under SnowLeopard 10.6.8.
This is unfortunately the latest system version supported on this hardware
and, after carefully searching the Apple Developer web site, my Xcode version
is the latest one I can install.
This seems to preclude my use of FreePGI unless there is a way around to define the required environment variables.

Thanks for replying,
Regards,

Louis

Currently, we do an Xcode license agreement check in a file:
/Library/Preferences/com.applt.dt.Xcode.plist which does not exist for Xcode 3.2.6. We will do our best to get the fix in the next release. In the meantime, there are 2 scripts in the Resources/pgi/osx86-64/14.3/bin called launch_pgi.csh/sh. Try to source one of those files based on your shell. They set the environments for compilers.

Hongyon

Hi hongyon2,

Sorry for the late reply.

Sourcing launch_pgi.sh (x86 or x86_64) indeed does the trick and starts
the “Free PGI” terminal with required environment.

I can now start compiling my fortran sources!

Thanks for your reply,

Louis