FreePGI fails on iMac with El Capitan

After upgrading my OS X to El Capitan 10.11.1, FreePGI complains with a pop-up window “the command exited with a non-zero status”. Then I tried to reinstall FreePGI by downloading FreePGI-157.dmg and exactly the same message appears. There were no problems using it with previous versions (Yosemite), so this may be an incompatibility specific to OS X 10.11.1 ?

It seems that the new version 7.1 of XCode (updated for El Capitan) needed to be launched first and agreed to the terms and conditions. Then, after quitting XCode, FreePGI worked just fine with no error messages.

Still have a problem with: ld: file not found: /usr/lib/crt1.o

I tried the fix for Yosemite but the permissions on /usr/lib are locked
down so the ln -s fix does not work. Thanks!

I suggest you download the 15.10 Free PGI version, and not the 15.7 version.

Remove all versions of PGI, make sure the Xcode is installed and
the license assents are agreed to, and then install the download.

Never assume the PGI compilers will work after an OS version upgrade or
an Xcode upgrade. If they work, okay. If not, remove and install the current
PGI release, if possible.