Full Minecraft for Jetson Nano

Has anyone tried installing the full linux version of Minecraft on the Jetson Nano? Is this possible?

I tried it didn’t work

Hi, I managed to do it by following this tutorial https://www.raspberrypi.org/forums/viewtopic.php?t=219438 (the Raspberry has the same ARM architecture as the Nano) and then replaced the natives (the ones in ~/Minecraft/Natives not in ~/.minecraft) by the ones that i got on the step 3 of this page https://www.96boards.org/blog/minecraft-dragonboard/ . Just make sure you replace “i386” by “arm” in the file lwjgl/platform_build/linux_ant/build.xml before you compile with ant.
Just so you now I got minecraft to run with these steps, but the FPS performance is really bad so it might not be the best solution.

I set mine up to do this some time ago. Didn’t take much tweaking. Downloaded java aarch64 . Then downloaded mc-server-installer from the snap store. Works great at 4gb if you do all the memory tricks. Even runs the latest snapshots.
Running the java launcher works. But I was not a fan of how it ran. Even at 2gb my frame rate was terrible. Doing the server is a lot of fun. Everyone in my house plays on it. If you have your heart set on it though. Download minecraft pi and connect to the server that way. Works better than the launcher still.