Full root

Hello. I tried to install OpenCV 3.4.0 with CUDA from this script: https://github.com/jetsonhacks/buildOpenCVTX1. I plugged USB 32GB disc, but I think that becuase of no permission the sources was not downloaded to USB. During the compilation I got no disc space left error, and when checked USB drive (in /media/nvidia/USBDisc) I got permission error. When solved that problem and entered the disc, it was empty. Instead of that I got message that /dev/root is 100% used and my GUI is blinking and not loading properly. Tried to remove opencv sources from eMMC but cannot localize them. Can you help me?

The jetsonhacks script downloads the opencv source tree into your home directory by default, unless you’ve specified an alternate directory with -s.

So, assuming you are user nvidia, you may cleanup with:

rm -rf /home/nvidia/opencv*

The problem is I run the script as

sudo ./buildOpenCV.sh --sourcedir 'media/nvidia/USBDisc'

But I can’t found opencv sources neither in the usb disc neither in /home/nvidia/ (or is it hidden somehow?)

You might have missed the leading ‘/’, so it may have created a ‘media’ directory from where you’ve run the script, or just failed to cd there.

If you don’t know where it is, you may try find:

find /home -name opencv

# If not found in /home, retry from the fs root, this may take some time:
find / -name opencv

Furthermore, I don’t think it is a good idea to run the script as root. The script uses sudo when it needs root access and would prompt for password if any. It would be better to keep your sources owned by nvidia user.

find /home -name opencv

Found nothing

While

find / -name opencv

# Found

find: ‘/run/user/1001/gvfs’: Permission denied
find: ‘/proc/9141’: No such file or directory
/usr/lib/aarch64-linux-gnu/opencv
/usr/lib/aarch64-linux-gnu/opencv/samples/android/15-puzzle/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/samples/android/image-manipulations/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/samples/android/tutorial-1-camerapreview/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/samples/android/camera-calibration/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/samples/android/tutorial-3-cameracontrol/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/samples/android/mobilenet-objdetect/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/samples/android/tutorial-2-mixedprocessing/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/samples/android/tutorial-4-opencl/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/samples/android/face-detection/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/samples/android/color-blob-detection/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/platforms/android/service/engine/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/platforms/maven/opencv
/usr/lib/aarch64-linux-gnu/opencv/platforms/maven/opencv-it/src/test/java/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/modules/java/generator/src/java/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/modules/java/generator/android/java/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/modules/java/generator/android-21/java/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/modules/java/test/pure_test/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/modules/java/test/common_test/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/modules/java/test/android_test/src/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/build/configured/modules/java/generator/src/java/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/build/configured/modules/java/generator/android/java/org/opencv
/usr/lib/aarch64-linux-gnu/opencv/include/opencv

But these one are from kernel I think? Before that I ofc have run

sudo apt-get purge libopencv*

Seems it has downloaded into /usr/lib/aarch64-linux-gnu and tried to build there, I don’t have such an opencv directory in my system.
You would thus clean up with:

sudo rm -rf /usr/lib/aarch64-linux-gnu/opencv

I have now used 9GB/15GB, so 5GB free. Thanks for help, I will try to compile it from USB now (will check double if i have permissions and ‘/’ before media).

BTW. What for is aarch64-linux-gnu strictly for (I am totally new to Linux)?

aarch64-linux-gnu is the ABI.
For example, the TK1 was armhf-linux-gnu because the processor was a arm32 bits with hardware floating point support. aarch64-linux-gnu is the default ABI on jetson TX1/TX2. So in /usr/lib/aarch64-linux-gnu/ there will be aarch64-linux-gnu ABI compatible libraries.