G_object_get: assertion 'G_IS_OBJECT (object)' failed

• Hardware Platform (Jetson / GPU) Jetson
• DeepStream Version 5.0.1
• JetPack Version (valid for Jetson only) 4.5/4.4
• TensorRT Version 7.1.3.4
• Issue Type( questions, new requirements, bugs) bugs
• How to reproduce the issue ?)
Using a docker with nvcr.io/nvidia/deepstream-l4t:5.0.1-20.09-base and the deepstream-app binary file (copied into the docker), every frame (deepstream-app:7): GLib-GObject-CRITICAL **: 12:31:25.644: g_object_get: assertion ‘G_IS_OBJECT (object)’ failed is printed for some reason.
Using the same binary without docker doesn’t print this line.

[application]
enable-perf-measurement=0
perf-measurement-interval-sec=5
#gie-kitti-output-dir=streamscl

[source0]
enable=1
type=1
camera-width=4096
camera-height=2160
camera-fps-n=30
camera-fps-d=1
camera-v4l2-dev-node=100

[sink0]
enable=0
#Type - 1=FakeSink 2=EglSink 3=File
type=5
sync=1
source-id=0
gpu-id=0
qos=0
nvbuf-memory-type=0
overlay-id=1

[sink1]
enable=1
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265
codec=2
#encoder type 0=Hardware 1=Software
enc-type=0
sync=0
#iframeinterval=10
bitrate=2000000
#H264 Profile - 0=Baseline 2=Main 4=High
#H265 Profile - 0=Main 1=Main10
profile=0
output-file=out.mp4
source-id=0

[streammux]
gpu-id=0
##Boolean property to inform muxer that sources are live
live-source=1
batch-size=1
##time out in usec, to wait after the first buffer is available
##to push the batch even if the complete batch is not formed
batched-push-timeout=40000

Set muxer output width and height

width=4096
height=2160
##Enable to maintain aspect ratio wrt source, and allow black borders, works
##along with width, height properties
enable-padding=0
nvbuf-memory-type=0

If set to TRUE, system timestamp will be attached as ntp timestamp

If set to FALSE, ntp timestamp from rtspsrc, if available, will be attached

attach-sys-ts-as-ntp=1

[tests]
file-loop=0

this is the config.

“GLib-GObject-CRITICAL **: 12:31:25.644: g_object_get: assertion ‘G_IS_OBJECT (object)’ failed” is a low level error in common glib library. So it is hard to save where is the problem. Can you debug more in your docker?