G-Sync indicator never shows up

As the title says, I’m activating the G-Sync Visual Indicator but it never shows up.


Try to disable compositing for full screen apps, or all together.

Tried that, it made no difference.

Tell me what Desktop Environment you using, what settings you have on nvidia-settings panel, are you even in X11 and have nvidia drivers installed? Try to use a DE like i3, which has no pre-installed compositor and also disable composition pipeline in monitor settings all together.

Thanks. I’m using KDE on X11 with driver 430.26.
Do you want me to paste my nvidia-settings.rc?
I tried disabling composition pipeline, still nothing.
I’ll try with another DE.