Garbage Output on Windowxs XP x64

I created the simple default test project using the VS2005 Wizard 1.2. The project is supposed to simply copy “Hello CUDA!” from one array to another and print the result to the screen. The program compiles, links, and launches without any difficulty. However, the results are absolutely garbage.

__global__ static void HelloCUDA(char* result, int num)


	int i = 0;

	char p_HelloCUDA[] = "Hello CUDA!";

	for(i = 0; i < num; i++) {

		result[i] = p_HelloCUDA[i];



After the kernel is called, the result array is copied back to the host and printed. I see

I modified the test program to print out the CUDA device properties for any CUDA devices it found during initialization.

int count = 0;

int i = 0;


if(count == 0) {

	fprintf(stderr, "There is no device.\n");

	return false;


bool bFound = false;

for(i = 0; i < count; i++) {

	cudaDeviceProp prop;

	if(cudaGetDeviceProperties(&prop, i) == cudaSuccess) {

		if(prop.major >= 1) {

			std::cout << "Device Version: " << prop.major << "." << prop.minor << std::endl;

			std::cout << "Total Memory: " << prop.totalGlobalMem/(1024*1024*1024) << " GB" << std::endl;

			std::cout << "Multiprocessor Count: " << prop.multiProcessorCount << std::endl;

			bFound = true;




if(!bFound) {

	fprintf(stderr, "There is no device supporting CUDA.\n");

	return false;



The first system I tested on is running XP x64 with a Quadro FX 5600 (1.5 GB RAM). The above code reported finding a single 1.0 device with 1.0 GB of RAM. I have never run any other CUDA program on this particular system, so I tried another system which has been used successfully with other CUDA programs. The second system has a single QuadroPlex unit attached to it (2x Quadro FX 5600). The program still indicates a single 1.0 card with 1.0 GB of RAM and produces similar garbage output.

I have verified that I have all of the correct CUDA files (driver, toolkit, and SDK). I tried uninstalling all of them and reinstalling (making sure to do so in the prescribed order) and rebuilding.

Any thoughts or suggestions would be greatly appreciated.

Can you post full source?

Happily. :) (37.4 KB)

btw… I am working with the release x64 configuration.