Gazebo9 not installing

Hey guys,

I am trying to install gazebo9 onto my Jetson TX2. I am running Ubuntu 16.04, and am using the install script provided by gazebosim.org. When I try to run the script, it ends with the error message: E: Unable to locate package libgazebo9-dev.

When I try to install it manually using instructions provided by gazebosim.org, I also get the error: E: Unable to locate package gazebo9.

Has anyone else dealt with this issue?

thanks

I have also tried these suggestions: https://askubuntu.com/questions/378558/unable-to-locate-package-while-trying-to-install-packages-with-apt

Hi raisintoe, gazebo7 is the package included in the Ubuntu 16.04 repo. Ubuntu 18.04 is the distribution that includes gazebo9 in the repo.

Just some thoughts to share on the topic: The TX2 will be no different than other Ubuntu 16.04 installations regarding basic package tool operations. A regular installation probably won’t include the repository for dev packages. Documents on the internet will apply (except you want arm64 repositories, a desktop PC wants either amd64 or x86_64).

What you see may imply a need to add a repository, or to configure apt. See this:
https://askubuntu.com/questions/1002244/one-ubuntu-16-04-system-finds-the-package-libsqlite3-dev-but-another-does-not

If you can find any other dev package (e.g., “apt search libncurses5-dev” is popular since it helps with kernel config tools), but can’t find the particular one, then it implies it isn’t available (what @dusty_nv mentions). If you can’t see even the common known dev packages, then it implies the repository config is not enabled (and perhaps you need to enable dev repositories, and could then find out gazebo9-dev still doesn’t exist).

Also, consider there may be a “restricted”, “universe”, or “multiverse” repository needing to be added (“main” may not cover that package even if it is otherwise available).

Hmmm, I have Gazebo 9.5.0 on my laptop running Ubuntu 16.04.

I changed the install script to install version 7. When running the script, it processed a little further, then displayed this:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgazebo7-dev : Depends: gazebo7-common (= 7.0.0+dfsg-2) but 7.14.0-1~xenial is to be installed
E: Unable to correct problems, you have held broken packages.

linuxdev, how do I add an arm64 repository? Are you refering to a specific repository for gazebo? I have already applied the cammand ‘apt-add repository’ for main, restricted, universe and multiuniverse; all of which were already implimented. I am unfamiliar with searching for specific repositories, and adding them to my computer.

It looks like this command was successful:
ubuntu@tegra-ubuntu:~$ apt search libncurses5-dev
Sorting… Done
Full Text Search… Done
libncurses5-dev/xenial 6.0+20160213-1ubuntu1 arm64
developer’s libraries for ncurses

Aright, I got the answer here: http://answers.gazebosim.org/question/13624/i-could-not-install-gazebo7-in-ubuntu-mate-1604/

I had to download the specific package to prevent a later verson of gazebo7-common from installing: https://launchpad.net/ubuntu/xenial/arm64/gazebo7-common/7.0.0+dfsg-2

Thanks for the help guys.