GBE LED ACK(PIN194) still has pulse output when unplugged

Remark:

  1. Jetson_Nano Module:A B
  2. Self-developed carrier board:1 and 2
  3. NVIDIA carrier board:3
    See the attachment video for symptoms; Other tests are described below:
    1)When using A+1 or A+2, the network cable passes through the switch, and the network light flashing problem occurs in the test;
    2)When using B+1 or B+2, the network cable passes through the switch, and there will be no network light flashing problem;
    3)When using A+3, the network cable passes through the switch, and there will be no network light flashing problem;
    4)The above tests will not have a light flicker problem if they do not go through the switch;
    5)On devices that do not have network light flashing problems, check the system kernel printing information and find that every time the network cable is plugged in and unplugged, it will appear:
    eth0:link down
    eth0:link up

6)On the device with the network flashing problem, check the system kernel printing information and find that every time the network cable is plugged in or removed, it will not appear:
eth0:link down
eth0:link up
7)GBE Schematic design:

8)After testing, it was found that the above circuit was changed to the following circuit, and the network light flash failure disappeared

May I ask: What is the root cause of this problem? Thank you!

GBE Schematic design:

Hi, what’s the issue schematic and the difference on GBE part between your issue board and reference design (p3449)? Do you mean the issue disappeared after you change design to same as reference?

YES;
After testing, it was found that the above circuit was changed to the following circuit, and the network light flash failure disappeared

Still don’t know what changes you have done. It is a separated magnetics without connector in your first schematic, what’s the changes comparing to your issue schematic?

If you mean the filter capacitors, you can refer to this topic Jetson TX2 Gigabit Ethernet recommended schematic changed by NVidia, using one cap for better noise control.

the changes is:

“using one cap for better noise control.”-----I don’t understand why?

the problem is the Jetson_Nano Module or the carrier board schematic design issues? thanks.

Hi~ Trumany,

In case , the TX2(C02) reference design was using 4 separated capacitors topology for each transformer primary mid-point instead of a single one capacitor for better noise immunity.
@873992755 means why the Xavier(B03) reference design changed from “4-caps topology” to 1 capacitor(one capacitor to GND connecting the 4 primary mid-points) , what reasons NV changed back to 1 capacitor design?

Thanks~

1 Like

Hi 873992755,

Sorry for misunderstanding on this, as that topic clarified, four capacitors design is for better noise immunity based on layout design update on TX2. I don’t know why your connector has such issue of capacitors design causing light flash issue. Maybe you can check with the vendor of connector for the reason? It is a weird behavior…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.