gcc missmatch on fresh fedora 30 installation

I’ve installed fresh Fedora 30 system and followed those steps:

    dnf update dnf install kernel-devel kernel-headers gcc make dkms acpid libglvnd-glx libglvnd-opengl libglvnd-devel pkgconfig echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf Append ‘rd.driver.blacklist=nouveau’ to end of ‘GRUB_CMDLINE_LINUX=”…”‘. grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg dnf remove xorg-x11-drv-nouveau dracut /boot/initramfs-$(uname -r).img $(uname -r) systemctl set-default multi-user.target reboot

When tried to install Nvidia 435.21 driver I got an error during DKMS compilation. When tried to omit DKMS i got little bit more readable info:

The kernel was built with gcc version 9.1.1 20190503 (Red Hat 9.1.1-1) (GCC), but the current compiler version is cc (GCC) 9.2.1 20190827 (Red Hat 9.2.1-1).
>  cat /proc/version
Linux version 5.2.11-200.fc30.x86_64 (mockbuild@bkernel03.phx2.fedoraproject.org) (gcc version 9.1.1 20190503 (Red Hat 9.1.1-1) (GCC)) #1 SMP Thu Aug 29 12:43:20 UTC 2019
> gcc -v
gcc version 9.2.1 20190827 (Red Hat 9.2.1-1) (GCC)

I’ve tried reinstalling kernel* and gcc but that did not change anything. What I am doing wrong?

ps. I’ve checked my laptop which has fedora installed few years ago but always keepign it up to date as I was wondering if that ‘issue’ is isolated. It has no Nvidia GPU in it but I have there same ‘missmatch’ (?)

>uname -r
>cat /proc/version
Linux version 5.2.9-200.fc30.x86_64 (mockbuild@bkernel04.phx2.fedoraproject.org) (gcc version 9.1.1 20190503 (Red Hat 9.1.1-1) (GCC)) #1 SMP Fri Aug 16 21:37:45 UTC 2019
> gcc -v
gcc version 9.2.1 20190827 (Red Hat 9.2.1-1) (GCC)

You aren’t doing anything wrong, it’s just Fedora pushed GCC 9.2 update yesterday while the kernel is still built using the previous GCC release.

I’m pretty sure GCC 9.2/9.1 are almost perfectly compatible, so there must be some sort of override in DKMS to ignore GCC version.

The GCC 9.2 can’t compile some GCC 9.1 source file.

I workaround by downgrade to GCC 9.1 (packages are in fc31) and seem installer working well.