GeForce 6150Go - Random lock-ups with 304.108 driver

Hello,

I have had lock-ups and freezes with this card and the 304 branch for quite some time. With earlier 304 drivers I had the laptop lock up on me almost 5 times day and nothing but hitting reset would help. So I started using nouveau, but the experience wasn’t satisfying (rendering glitches on the desktop, slow performance) but at least no freezing.
I decided to return to the NVIDIA driver 3 days ago and was surprised that I could use my laptop for the entire day without problems. Just a few moments a go I had the UI of Google Chrome freeze on me, but I could still move my cursor and switch to TTY. In the past freezes usually made the screen go black and the laptop would not respond to any input. In the virtual terminal I discovered several NVRAM:Xid messages in dmesg output. When I switched back to X11, everything was repsonding again.
I did not do anything unusual that I haven’t done before in Chrome when this happened, so it is not reproducable just like all the freezes I had in the past.

UPDATE: I just had another look-up but this time the mouse froze and the screen went black after 1-2 seconds. My only solution was to hit reset and recover the kernel messages from systemd journalctl. The first Xid message is different from the one in the log that I attached where, the lock up wasn’t as extreme.

http://pastebin.com/xkjT7KVW
nvidia-bug-report.log.gz (71.2 KB)

Worth a try: Disable the “Allow Flipping” option in nvidia-settings. Performance will degrade just a tiny bit.

For years, I had to disable that, to avoid intermittent lock-ups every day or two.

Seems to be fixed with recent drivers, e.g. 325.15

Thank you. Unfortunately 325.15 is not an option with my card. I have not tried 304.116, since noone actively maintains the legacy driver for Arch Linux anymore, so I’ll have to package it myself. I’ll see if I can get two weeks without lock-ups out of this driver with disabled flipping. In that case I would consider it fixed.

UPDATE: Just had another lock-up where the UI would freeze but my mouse cursor still worked. The same Xid messages as the ones in the pastbin.

UPDATE2: Another partial lock-up. Chrome froze for a few seconds and now the fonts in the Tab Labels are scrambled. This time with another variation of the Xid messages.

[ 7903.769370] NVRM: Xid (0000:00:05): 13, 0000 e0016100 0000008a 00000104 000091d8 00000002
[ 7903.772031] NVRM: Xid (0000:00:05): 9, Channel 00000020 Instance 00000000 Intr 00100000
[ 7903.774292] NVRM: Xid (0000:00:05): 9, Channel 00000020 Instance 00000000 Intr 00100000
[ 7903.776538] NVRM: Xid (0000:00:05): 9, Channel 00000020 Instance 00000000 Intr 00100000
[ 7903.778788] NVRM: Xid (0000:00:05): 9, Channel 00000020 Instance 00000000 Intr 00100000
[ 7903.781048] NVRM: Xid (0000:00:05): 9, Channel 00000020 Instance 00000000 Intr 00100000

blackout24, Please provide reproduction steps in detail? What desktop env you are using? What is repro rate ? What action triggers this issue? Is this specific to any card OR OS ? Any previous driver worked without this issue?

Hello,

I already said this happens randomly and previous drivers had the same problem. Desktop is Gnome 3.10.

“Is this specific to any card OR OS ?”

Don’t know what you mean I only have one card and operating system.

I updated to 304.116 which is now in [testing] on Arch. I will see if the laptop still locks-up from time to time. I will once again try to get 2 weeks of usage out of it without a lock up and I would consider it fixed with the new driver. I will update this post.

EDIT: The laptop locked up yesterday with 304.116.