GeForce GT 740M on Ubuntu 18.04 installs but the driver is not being used

I install the driver but the system shows that the nvidia driver is not being used. I already tried a bunch of things like: purge and reinstall the driver, all the others avaiable drivers, even the .run download from the nvidia site, blacklist nouveau, ocl-icd-libopencl1, bumblebee and probably some others i can’t even remember now. All of this were done isolated and in combination with each other, by undoing the modificatons i had done or by formating and starting all from scratch.
I don’t thing the problem is a hardware one because everything works fine on windows.
Here are some information:

Notebool Dell Vostro 5470
Nvidia Geforce GT 740M
Ubuntu 18.04.4

uname -a
Linux darkstar 5.3.0-42-generic #34~18.04.1-Ubuntu SMP Fri Feb 28 13:42:26 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

lspci | egrep ‘VGA|3D|Display’
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
09:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)

sudo nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

glxinfo | grep render
direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
GLX_MESA_query_renderer, GLX_MESA_swap_control, GLX_OML_swap_method,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa DRI Intel® Haswell Mobile
GL_ARB_compute_shader, GL_ARB_conditional_render_inverted,
GL_NV_compute_shader_derivatives, GL_NV_conditional_render,
GL_ARB_compute_shader, GL_ARB_conditional_render_inverted,
GL_NV_compute_shader_derivatives, GL_NV_conditional_render,
GL_EXT_read_format_bgra, GL_EXT_render_snorm, GL_EXT_robustness,
GL_NV_conditional_render, GL_NV_draw_buffers, GL_NV_fbo_color_attachments,
GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

sudo prime-select query
nvidia

About feature of gnome
Processor Intel® Core™ i7-4500U CPU @ 1.80GHz × 4
Graphics Intel® Haswell Mobile[nvidia-bug-report.log|attachment]

I folloed this instructions: " Please always include a copy of an nvidia-bug-report.log.gz file, which can be generated with the nvidia-bug-report.sh script shipped with the NVIDIA Linux/FreeBSD graphics drivers and installed in your PATH; the log file will be placed in the current working directory. Attach the log file by clicking the Upload upload button in the post composition window."
But received this message: “Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, log).”
So i removed the .gz from the file nvidia-bug-report.log.gz

(upload://jPhdaPqTxmOv2wpfPDxBQaCnDhA.log) (76.4 KB) nvidia-bug-report.log (76.4 KB)

1 Like

You have a v415 driver installed which is too old for the currently running 5.3 kernel. You should be able to select a current 440 driver from the Software&Updates application.

Tried to install v440 via software update and rebooted.
sudo nvidia-smi
No devices were found

Then i tried your answer in another post which solved that problem (NVIDIA-SMI driver problem on Ubuntu 18.04)

sudo apt install --reinstall nvidia-driver-440
dkms status
nvidia, 440.64, 5.3.0-45-generic, x86_64: installed

sudo dkms install nvidia/440.64 --all
Module nvidia/440.64 already installed on kernel 5.3.0-45-generic/x86_64

sudo apt install --reinstall linux-headers-5.3.0-45-generic

dkms status
nvidia, 440.64, 5.3.0-45-generic, x86_64: installed

sudo update-initramfs -u

rebooted

sudo nvidia-smi
No devices were found

Some additional info:

v440.64 doesn’t seem to support GT 740m
driverResults.aspx/157462/en-us

The .run version recommended by nvidia when manually downloaded from the site is 418.113
driverResults.aspx/153787/br

Installing v418 will actually install v430.64 which does not support GT 740m
sudo apt show nvidia-driver-418
Package: nvidia-driver-418
Version: 430.64-0ubuntu0~gpu18.04.1
driverResults.aspx/153714/en-us

sudo apt show nvidia-driver-415
Package: nvidia-driver-415
Version: 415.27-0ubuntu0~gpu18.04.2
This version supports GT 740M
driverResults.aspx/141847/en-us

sudo apt show nvidia-driver-390
Package: nvidia-driver-390
Version: 390.132-0ubuntu0.18.04.1
This version supports GT 740M
driverResults.aspx/153832/en-us

GeForce Experience on windows installs version 425.31

New users can only post 2 links, so a removed the https://www.nvidia.com/Download/ and posted only the sequence in case it’s needed.

On Linux, the 740M is well supported by the latest 440.64 driver, only on Windows support has been dropped after 425.
Please try this:

  • make sure nvidia-prime is installed (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
    If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.

sudo apt install nvidia-prime
nvidia-prime is already the newest version (0.8.8.2).

sudo prime-select nvidia
Info: the nvidia profile is already set

/etc/modprobe.d/blacklist-nvidia.conf doesn’t exist. I removed nvidia-modeset.conf which was manually created and was empty by the time i posted the question.

/lib/modprobe.d/blacklist-nvidia.conf doesn’t exists either, instead there is a nvidia-graphics-drivers.conf which i removed
cat nvidia-graphics-drivers.conf
blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

Just notice a file /lib/modprobe.d/nvidia-kms.conf. I didin’t change the value
cat nvidia-kms.conf
#This file was generated by nvidia-prime
#Set value to 0 to disable modesetting
options nvidia-drm modeset=1
sudo update-initramfs -u

rebooted

Gnome took a long time to initiate and became very slow.

htop
/lib/systemd/systemd-journald is constantly consuming ±25% of CPU

tty via ctrl + alt + f3
Don’t show login, instead is repeating this:
[ “changing numbers”] nouveau 0000:09:00.0: fifo: SCHED_ERROR 06[ ]

/etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”

Decompressed file nvidia-bug-report is too big. Renamed to exclude .gz
nvidia-bug-report.log (380.6 KB)

That was a needed file to blacklist drivers that block the nvidia driver. Please recreate it and run sudo update-initramfs -u afterwards.

recreated /lib/modprobe.d/nvidia-graphics-drivers.conf
cat /lib/modprobe.d/nvidia-graphics-drivers.conf
blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

sudo update-initramfs -u
rebooted

sudo nvidia-smi
No devices were found

nvidia-bug-report.log (1.1 MB)

Doesn’t look good:
[ 46.224819] NVRM: GPU 0000:09:00.0: RmInitAdapter failed! (0x25:0x40:1199)
Looks like the gpu is broken. Did you check if it works in Windows?

Yes, it works in Windows.

I had never tested the nvidia instalation in Linux, just assumed it was working because after installing the driver the hdmi port started to function. But i recently installed folding@home program (fahclient and fahcontrol) and noticed that only the CPU was being used. When i tried to use the GPU, the program returned an error relative to opencl and cuda. To test if it was a Linux or hardware problem i installed fahclient in windows and the GPU worked without any problems. Then i got back to Linux and tried a ton of things, some described in the first message, some that i don’t even remember. Installed nvida-cuda-toolkit, installed the .run from nvidia, installed cuda using the official manual. During this process i tried combinations of things, reverted the modifications to try others things or formatted to start from scrath. Eventually i was able to use the GPU in linux fahclient, but at some point fahclient couldn’t use the GPU anymore, i don’t remember if was after a system upgrade or a clean install of ubuntu.

Ok, please check if a kernel <5.3 works.

Any updates on this issue. I tried driver 450.36.06 and still can’t make it work.

I also tried some benchmarks where I could visualize GPU utilization (links bellow), but when I run deepstream they display nothing.


Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

I already formated my Laptop and now I have driver 440. I’ll try to get driver 450 again and then send bug report.

nvidia-bug-report.log.doc (1.4 MB)

The gpu and driver are running fine, it’s just not used for X. Try this:

  • make sure nvidia-prime is installed (sudo apt install nvidia-prime)
  • switch to nvidia (sudo prime-select nvidia)
  • remove stray blacklist files (sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf)
  • update the initrd (sudo update-initramfs -u)
  • reboot
    If this doesn’t resolve the issue, please create a new nvidia-bug-report.log.