GeForce GT220 problems with Cuda/driver/X...

I just placed a GeForce GT220 into a machine and have been having some issues with it…

  • I can run Cuda programs just fine if I log into the machine remotely and use X Window forwarding
  • I cannot run any Cuda programs from the machine itself when logged into X Windows
  • I cannot run any Cuda programs remotely if somebody on the machine logged into X Windows

In the situations where it doesn’t work just calling cuInit(0) fails and returns 100.
Has anybody else encountered this problem, or know of a workaround?

I’m running Fedora 11 on the machine with Xorg 1.6.2, and I have tried the 190.18 and 190.53 drivers. I sure would like to view my programs from the machine I’m running them on.

Can’t help with this specific problem, but I can report using GT220’s in 2 machines (one with DDR3, 1 with DDR2), under ubuntu 9.10 (32 bit), and on 190.42 with no problems (well once I had done the twiddles for the latest C++ compiler).

Problem solved!

It turns out that the problem was that I was running the Cuda program as a different user than what was logged in to X. When I logged into X, /dev/nvidiactl becomes owned by that user, so another user was unable to use it through the Cuda libraries.