GeForce GTX 1050 problem with driver

Hello everyone,

Recently I bought new laptop with GeForce GTX 1050 graphic card and installed Ubuntu 18.04 LTS 64 bit OS. I have installed


and after that I’m able to run


to get results about graphic card but it shows that no processes are running connected to this hardware. Command

prime-select nvidia


prime-select query

shows that nvidia is set and selected, but instead of it integrated graphics is used. Opening nvidia settings GUI displays blank screen. I know for sure that graphic card works perfectly because Windows 10 is installed alongside Ubuntu 18.04.

Does anyone have some suggestions to overcome this issue? I will post any additional details per request. Help will be much appreciated.

New input with a lot of informations. I have reinstalled OS (Ubuntu 18.04 LTS 64b - kernel 5.3.0-42-generic) and after update got option to install nvidia-435 (proprietary, tested). Running nvidia-smi gives output but no running processes found. Running nvidia-settings opens app but with limited options. This is what I get in terminal:

ERROR: Error querying enabled displays on GPU 0 (Missing Extension).
ERROR: Error querying connected displays on GPU 0 (Missing Extension).

** Message: 11:05:22.351: PRIME: No offloading required. Abort
** Message: 11:05:22.351: PRIME: is it supported? no

ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation. The application profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed in the help text. Please see the README for possible values and descriptions.

I strongly believe that solution is few terminal commands away. Is it possible for someone to help me with this issue? I’ve been trying to find solution for more than two and a half weeks now. So frustrating but I didn’t give up. Anyone willing to help me to win this fight?

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

nvidia-bug-report.log (2.0 MB)

Hi, here’s nvidia bug report.
Looking forward to finding the solution.

Ok, it’s an AMD/Nvidia combo which doesn’t yet work ootb with ubuntu, needs some minor manual tweaks:

Thanks generix, this tweak worked. I have to add that it works like a charm on external monitor. Problem solved.