Geforce GTX 750Ti not working with nvidia drivers

Hi everyone.
I recently bough a second hand Geforce GTX 750Ti.
I managed to get it working by using nouvaeu driver, however when I tried to use nvidia proprietary drivers it failed.
I am running Debian Testing/Buster and i tried the GPU on two different Towers one with a Xeon E3-1220 v5 and the other one with an i7-2600k).

I actually upgraded to Testing in order to try if updating the kernel would solve the issue, but it didn’t.
The two kernel versions are 5.4.0-4 for Testing and 4.19.0-8 for buster.

I tried both the drivers from the nvidia website and the ones packaged in debian (both the ones in buster-backports and the ones in buster).

In the end every attempt fail when the system (or me ) tries to load the nvidia kernel module.
The error is always No such device.
Here is the output of modprobe nvidia_current -vv:

modprobe: INFO: ../libkmod/libkmod.c:365 kmod_set_log_fn() custom logging function 0x55b98e44c330 registered
install modprobe -i nvidia-current $CMDLINE_OPTS 
modprobe: INFO: ../libkmod/libkmod.c:365 kmod_set_log_fn() custom logging function 0x55b6a8d7a330 registered
insmod /lib/modules/5.4.0-4-amd64/updates/dkms/nvidia-current.ko 
modprobe: INFO: ../libkmod/libkmod-module.c:892 kmod_module_insert_module() Failed to insert module '/lib/modules    /5.4.0-4-amd64/updates/dkms/nvidia-current.ko': No such device
modprobe: ERROR: could not insert 'nvidia_current': No such device
modprobe: INFO: ../libkmod/libkmod.c:332 kmod_unref() context 0x55b6a9858440 released
modprobe: ERROR: ../libkmod/libkmod-module.c:990 command_do() Error running install command 'modprobe -i nvidia-      current ' for module nvidia: retcode 1
modprobe: ERROR: could not insert 'nvidia': Invalid argument
modprobe: INFO: ../libkmod/libkmod.c:332 kmod_unref() context 0x55b98f5c5430 released

This is the output of lspci -s 01:00 -vv :

0000:01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a1) (prog-if 00 [VGA controller])
Subsystem: NVIDIA Corporation GM107 [GeForce GTX 750 Ti]
Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 16
Region 0: Memory at f4000000 (32-bit, non-prefetchable) [size=32M]
Region 1: Memory at e0000000 (64-bit, prefetchable) [size=128M]
Region 3: Memory at e8000000 (64-bit, prefetchable) [size=64M]
Region 5: I/O ports at e000 [size=128]
Expansion ROM at f6000000 [disabled] [size=512K]
Capabilities: <access denied>
Kernel modules: nvidia

Following some hints online I tried adding this to my kernel parameters:
without luck.

You can find the bug report attached.
nvidia-bug-report.log (475.1 KB)

Any hint?

Thanks, Gabriel

I’m sorry, this is a fake card, it’s a bios modified GTS450, GF116. That one is only supported up until the v390 driver. You should try to get your money back.
That card also won’t run stable with the legacy driver due to the memory amount is also fake, it will crash if something allocates more than 1GB of video memory.

1 Like

Thanks for the prompt answer, I opened a complaint with the seller. Can you point me where you got this information that is fake? Is it in the bug report or somwhere in lspci ?


In dmesg, the driver reports that it’s incompatible and the 390 legacy driver has to be used.
sudo lspci -d 10de:*
shows also the audio device, which reports the correct chip, GF116. ‘F’ stands for Fermi.

1 Like

Fortunately I got refunded from the vendor, however he didn’t asked for the return of the video card.
Is there a way to flash the right bios onto this video card and use it somehow?

Yes, but you would need a hardware programmer since software reflashing has been locked on those fake cards.
Though it’s not really usable, a GTS450 just draws a lot of power for the performance of a current intel integrated gpu.

it’s a GTX 550-Ti, I’d just use it a few days for cuda debugging, while i wait for the new one to arrive.
I tryied nvflash without luck. Any way to use it with the appropriate nvidia driver?

Not really. Like said, the memory amount is also fake. Fermi supports only cuda 8, btw.

A possibility would be to load the correct bios from file: