[Geforce RTX 2060 mobile] : Debian 11 (xfce) / HDMI not recognize

Hello everybody,

I have a dual boot (win 11/debian 11) on a MSI GL75 9SE .

my graphics config are :

Graphics: Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Micro-Star MSI driver: nvidia v: 460.91.03
bus ID: 01:00.0
Device-3: Acer HD Webcam type: USB driver: uvcvideo bus ID: 1-13:4
Display: server: X.Org 1.20.11 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1920x1080~120Hz

And my problem is that the HDMI (connected to a screen SAMSUNG U28E590D) is recognize automatically on windows 11 but not on Debian 11.

I have attached the log to this message
nvidia-bug-report.log.gz (239.5 KB)

Thanks a lot for any help !

It seems you have bbswith+bumblebee installed which unloads the nvidia driver on boot. Please uninstall both. Furthermore, please add the nvidia modules to the initrd so it loads earlier.
Then you’ll likely end up in offload mode so you’ll have to run
xrandr --setprovideroutputsource NVIDIA-G0 modesetting && xrandr --auto
to enable the monitor connected to the nvidia gpu.
Check if the provider are available:
xrandr --listproviders

Hello @generix ,

thanks a lot for your answer.

I have uninstalled bumblebee and bbswitch-dkms

Can you be more specific ? Sorry but I am a newbie and a little be more step by step would be very very nice of you.

For this step all I have to do is type in a terminal :
a) xrandr --setprovideroutputsource NVIDIA-G0 modesetting && xrandr --auto

?

I have to run these command to seek which provider ?

For now the output of these command is

Providers: number : 2
Provider 0: id: 0x43 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 1 associated providers: 0 name:modesetting
Provider 1: id: 0x28c cap: 0x2, Sink Output crtcs: 4 outputs: 3 associated providers: 0 name:NVIDIA-G0

Adding the modules to initrd:
https://forums.developer.nvidia.com/t/linux-mint-nvidia-driver-loads-with-startx-but-not-on-initial-startup/168262/2

I have to run these command to seek which provider ?

NVIDIA-G0 and modesetting, they’re obviously there.

For this step all I have to do is type in a terminal :

Yes.

@generix
Thanks a lot it’s working !!!