GeForce RTX 3050 Ti Laptop GPU with 510.60.02 Driver crashes in Performance Mode

Hi, I’ve tried searching and can’t find similar a topic to this. Hopefully someone can help.

I have a brand new laptop with GeForce RTX 3050 Ti running Mint 20.3 Cinnamon (although I have tried LMDE5 & Mint Mate 20.3 and seen the same issue).

I installed driver version 510.60.02 and it defaults to NIVIDIA on Demand mode. If I change it to NVIDIA Performance Mode and reboot the machine crashes immediately after the LUKS disk decryption password is entered. No messages displayed, black screen.

I can’t get out of it and the only thing I have been able to do to get past is to reboot and reinstall the OS.

Is there any way I can enable the Performance Mode without the system hanging on boot? Unfortunately I’m not sure how to get logs from the hung system.

I’ve tried to include as much info as possible. If anything else is needed I will provide also.

System Info:

System: Kernel: 5.13.0-40-generic x86_64 bits: 64 compiler: N/A Desktop: Cinnamon 5.2.7
wm: muffin dm: LightDM Distro: Linux Mint 20.3 Una base: Ubuntu 20.04 focal
Machine: Type: Laptop System: PC Specialist product: NP5x_NP7xHH_HJ_HK v: N/A serial:
Chassis: No Enclosure type: 10 serial:
Mobo: CLEVO model: NPxxHJ_HK_HH serial: UEFI: INSYDE v: 1.07.03TPCS
date: 07/02/2021
Battery: ID-1: BAT0 charge: 47.8 Wh condition: 47.8/48.3 Wh (99%) volts: 17.2/15.2
model: Notebook BAT serial: status: Full
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M315/235/317 serial:
charge: 100% (should be ignored) status: Discharging
CPU: Topology: 8-Core model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP arch: N/A
L2 cache: 24.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 73728
Speed: 1423 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 4050 2: 1302 3: 3526
4: 3825 5: 4455 6: 3242 7: 800 8: 4500 9: 1674 10: 3339 11: 4525 12: 1479 13: 2616
14: 801 15: 1111 16: 1640
Graphics: Device-1: Intel vendor: CLEVO/KAPOK driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:9a60
Device-2: NVIDIA vendor: CLEVO/KAPOK driver: nvidia v: 510.60.02 bus ID: 01:00.0
chip ID: 10de:25a0
Display: x11 server: X.Org 1.20.13 driver: modesetting,nvidia
unloaded: fbdev,nouveau,vesa resolution: 1920x1080~144Hz
OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.2.6
direct render: Yes

Additional - I’ve just tried enabling “nomodeset” in grub in the hope that this would fix it after reading this in other forums. I also disabled “quiet splash” in the hope of capturing an error message.

Unfortunately once I enable Performance Mode same behaviour again. Once all the boot messages scrolled past the system hung with a black screen and no response to an key presses/combos.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

The machine is currently hanging on boot because I tried to enable performance mode again.

I can boot from external media and access the file system - is there a way to change the settings back to Nvidia on Demand by editing a config file somewhere just to get it to boot and run the nvidia-bug-report.sh script or will I need to reinstall the OS again as I have been doing?

Does booting to recovery mode also doesn’t work?
Or just boot without graphics by appending
systemd.unit=multiuser.target
to kernel cmdline in grub menu.

Got in via recovery console.

nvidia-bug-report.log.gz (281.2 KB)

Please remove the nomodeset kernel parameter.

OK but I only added that in a while ago to see if it would make a difference. If I remove it then I will have rolled back to situation in the original post above.

A bug-report.log is needed from that state. The nvidia driver is working fine according to the logs. Your internal display is driven by the intel igpu, nomodeset disables it. If there’s something wrong when ‘nomodeset’ is removed, it points to something being wrong with the i915 driver.

Understood. Here it is.
nvidia-bug-report.log.gz (257.2 KB)

You attached the old log.

No, they’re different. Look at the file size and time stamps.

original…

nvidia-bug-report.sh Version: 31082725

Date: Fri 29 Apr 13:08:33 BST 2022

Latest…

nvidia-bug-report.sh Version: 31082725

Date: Fri 29 Apr 13:28:27 BST 2022

OK, this is weird. I just ran update-grub again without making any changes /etc/default/grub and it’s booted properly and the driver is now in performance mode.