Gentoo on Jetson TK1

Hi,

I am currently trying to get Gentoo to work on my Jetson TK1. However so far, I did not get a completely usable system.

Here is what I have tried so far:

  1. Install u-boot and the system following http://elinux.org/Tegra/Mainline_SW/Gentoo_From_SD_Card.
    -> No success. The board does not start, nothing is shown over UART.

  2. Modify the instructions at http://archlinuxarm.org/forum/viewtopic.php?f=49&t=7493 for installing a gentoo rootfs. I used a 3.17 and 3.17.1 mainline kernel.
    -> System starts, I can log in, but I get strange graphics faults (normally works). Also most HW does not work (e.g. ethernet). Looks like PCIe support is still missing.

  3. Try to use the kernel sources from https://developer.nvidia.com/linux-tegra-rel-19 together with U-Boot and a gentoo rootfs.
    -> Kernel wont start, last message on UART “starting linux kernel” or something similar.

From other postings I have gathered, that support for jetson-tk1 is still rudimentary in mainline. So this probably explains why PCIe does not work. So I should probably focus my efforts on the nvidia kernel.

However, what could be the reason why the kernel provided by nvidia does not work from u-boot? Looking through the kernel sources, I found that there are differnet device tree files for the nvidia kernel (tegra124-pm375) and the mainline one (tegra124-jetson-tk1). I tried to use both device trees, but I am not sure how to check in u-boot which DT was loaded.

Has anybody else had success starting the nvidia kernel from u-boot, or is there any other version of the kernel which has better HW support than the mainline one?

I have managed to get Gentoo to work from eMMC the NVidia kernel. A tutorial can be found here http://elinux.org/Tegra/Downstream_SW/Gentoo_From_eMMC.

With small modification this tutorial should also work for the Grinch kernel.

Thanks for the wiki page but I think you should move it to a different location as I think the Mainline_SW refers to using the upstream kernel and u-boot which your instructions are not using.

And yes, the upstream kernel is still missing a lot of features that are working in the NVIDIA’s downstream kernel. Fortunately upstream kernel is making nice progress and new features are being added all the time.

Moved it to downstream for now (although the distro is mainline, the kernel is not, so it’s somewhere in between). I’ll have a look at it once we get more input and more categories.