Geoclue error

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
[O] DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[O] Linux

Hardware Platform
[O] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
[O] native Ubuntu 18.04

when I run “sudo apt-get upgrade” command,

The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
I met the problem mentioned above,
I used “sudo apt-get --with-new-pkgs upgrade” to solve the problem, but it didn’t show any difference, giving another error instead. I mentioned below.

debconf: delaying package configuration, since apt-utils is not installed
dpkg: unrecoverable fatal error, aborting:
unknown user ‘geoclue’ in statoverride file
E: Sub-process /usr/bin/dpkg returned an error code (2)

Please let me know how to solve these problems.

I appreciate for your help.

Are you running the commands on the target or the host system?

Hello Vick :)
I ran that commands on target.

Did you see the problems right after flashing the target? Why do you need to upgrade it?

The reason for doing this is that xavier’s display is not connected. When flashing xavier, the error in the previous question (Avahi-daemon, utils issues)is not resolved and keeps occurring.

In the end, I deleted the avahi-daemon package of previous question, but this time the above question error occurred.

followed “Enable Display” in Finalize DRIVE AGX System Setup (Linux)?
How about enabling display without a desktop?
Have you tried another HDMI monitor?
any suspicious messages from syslog?