Getting deepvariant to actually not realign reads?

singularity run --nv -B /var/scratch/jdalglei:/var/scratch/jdalglei,/usr/lib/locale/:/usr/lib/locale/,/ceph/project/Wellcome_Discovery/jdalglei/:/ceph/project/Wellcome_Discovery/jdalglei/,/ceph/project/Wellcome_Discovery/jdalglei/:/ceph/project/Wellcome_Discovery/jdalglei/ docker://nvcr.io/nvidia/clara/clara-parabricks:4.3.0-1 pbrun deepvariant --mode pacbio --add-hp-channel --norealign-reads --in-bam=/tmp/pbrun-tmp/m64176e_230421_144242.hifi_reads.hg38.pb_aligned_sorted_haplotagged.bam --out-variants=/tmp/pbrun-tmp/m64176e_230421_144242.hifi_reads_deepvariant_recall_wh.vcf --ref=/tmp/pbrun-tmp/hg38.fa --num-cpu-threads-per-stream=112 --num-streams-per-gpu 2 --num-gpus=2 --tmp-dir ${TMPDIR} --num-gpus 2 --norealign-reads;
bgzip -i -f -@ 32 /tmp/pbrun-tmp/m64176e_230421_144242.hifi_reads_deepvariant_recall_wh.vcf;
INFO: Using cached SIF image
WARNING: While bind mounting ‘/ceph/project/Wellcome_Discovery/jdalglei:/ceph/project/Wellcome_Discovery/jdalglei/’: destination is already in the mount point list
Please visit NVIDIA Clara - NVIDIA Docs for detailed documentation

Detected 2 CUDA Capable device(s), considering 2 device(s)
CUDA Driver Version / Runtime Version 12.4 / 12.2
Using model for CUDA Capability Major/Minor version number: 86
/usr/local/parabricks/binaries/bin/deepvariant /tmp/pbrun-tmp/hg38.fa /tmp/pbrun-tmp/m64176e_230421_144242.hifi_reads.hg38.pb_aligned_sorted_haplotagged.bam 2 2 -o /tmp/pbrun-tmp/m64176e_230421_144242.hifi_reads_deepvariant_recall_wh.vcf -n 112 --model /usr/local/parabricks/binaries/model/80+/pacbio/deepvariant.eng -long_reads --sort_by_haplotypes --add_hp_channel --parse_sam_aux_fields -norealign_reads --vsc_min_fraction_indels 0.12 --track_ref_reads --phase_reads --pileup_image_width 199 --max_reads_per_partition 600 --partition_size 25000 --vsc_min_count_snps 2 --vsc_min_count_indels 2 --vsc_min_fraction_snps 0.12 --min_mapping_quality 1 --min_base_quality 10 --alt_aligned_pileup diff_channels --variant_caller VERY_SENSITIVE_CALLER --dbg_min_base_quality 15 --ws_min_windows_distance 80 --aux_fields_to_keep HP --p_error 0.001 --max_ins_size 10
[PB Info 2024-Mar-26 15:08:51] ------------------------------------------------------------------------------
[PB Info 2024-Mar-26 15:08:51] || Parabricks accelerated Genomics Pipeline ||
[PB Info 2024-Mar-26 15:08:51] || Version 4.3.0-1 ||
[PB Info 2024-Mar-26 15:08:51] || deepvariant ||
[PB Info 2024-Mar-26 15:08:51] ------------------------------------------------------------------------------
[PB Info 2024-Mar-26 15:08:51] Starting DeepVariant
[PB Info 2024-Mar-26 15:08:51] Running with 2 GPU devices, each with 2 group instances and 112 workers
[PB Info 2024-Mar-26 15:08:51] ProgressMeter - Current-Locus Elapsed-Minutes
[PB Info 2024-Mar-26 15:08:57] ProgressMeter - chr1:0 0.1
[PB Info 2024-Mar-26 15:09:03] ProgressMeter - chr1:0 0.2
[PB Info 2024-Mar-26 15:09:09] ProgressMeter - chr1:0 0.3
[PB Info 2024-Mar-26 15:09:15] ProgressMeter - chr1:0 0.4
[PB Info 2024-Mar-26 15:09:21] ProgressMeter - chr1:0 0.5
[PB Info 2024-Mar-26 15:09:27] ProgressMeter - chr1:0 0.6
[PB Info 2024-Mar-26 15:09:33] ProgressMeter - chr1:0 0.7
[PB Info 2024-Mar-26 15:09:39] ProgressMeter - chr1:0 0.8
[PB Info 2024-Mar-26 15:09:45] ProgressMeter - chr1:0 0.9
[PB Info 2024-Mar-26 15:09:51] ProgressMeter - chr1:0 1.0
[PB Info 2024-Mar-26 15:09:57] ProgressMeter - chr1:0 1.1
[PB Info 2024-Mar-26 15:10:03] ProgressMeter - chr1:0 1.2
[PB Info 2024-Mar-26 15:10:09] ProgressMeter - chr1:0 1.3
[PB Info 2024-Mar-26 15:10:15] ProgressMeter - chr1:0 1.4
[PB Info 2024-Mar-26 15:10:21] ProgressMeter - chr1:0 1.5
[PB Info 2024-Mar-26 15:10:27] ProgressMeter - chr1:0 1.6
Warning: The alignment path of one pair of sequences may miss a small part. [ssw.c ssw_align]
[PB Info 2024-Mar-26 15:10:33] ProgressMeter - chr1:0 1.7

I’m finding that I still get errors which denote that striped smith waterman is being used. Is this typical? There was some configuration that I used before that was much faster and didn’t get stuck realigning. I’ve put --norealign-reads in twice and it doesn’t seem to respond to this flag. Is there some other flag I’m using that is negating it?

I believe I may have found a bug-- essentially the pacbio mode preset results in a -norealign_reads rather than a --norealign_reads and ignores any other flags, from what I can tell.