Getting "devmem: mmap: Operation not permitted" when attempting to test PCIe

Hi. I have two Jetson AGX Xaviers. I am attempting to test PCIe using these two Xaviers using the following documentation from NVIDIA:

As mentioned in the above documentation, I flash one Xavier as root port, and the other as end point. I follow the instructions, and am able to follow them till the point where I get the end point’s BAR address. My end point BAR address was:
BAR0 RAM phys: 0x108338000

After that, the next step mentioned in the documentation is to read the end point memory using the following command:

Based on this, I entered the following command:
busybox devmem 0x108338000

However, when I run this command on the end point, I get the following message:
devmem: mmap: Operation not permitted.

Memory write using the busybox devmem command also gives same error message.
( For reference, memory write command used was:
busybox devmem 0x108338000 32 0xfa950000

How do I resolve this issue? I am running Jetpack 5.1 on both the root port and the end point.

My bad. I was looking at the wrong documentation. Jetpack 5.1 uses R35.2.1 BSP, while I was looking at documentation of R34.1. When I go to the documentation for R35.2.1, I can see that I need to recompile the kernel:

I am currently attempting to recompile the kernel as stated in the documentation. Will mark this as the solution if this resolves the issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.