Getting error with image sensor LP state error

Hi,

We are currently testing ar1820 image sensor through mipi interface of tegra K1 development.

We are able to write (Configure) the ar1820 registers through v4l2 I2C driver.

Device is also detected (/dev/video0). When we try to capture the image through yavta utility, it throwing the following error.

Checking Sync time out for CSI Port A
[ 2264.743790]
[ 2264.743790] cam->syncpt_id_csi_a: 13; cam->syncpt_csi_a:74
[ 2265.243744] vi vi.0: CSI_A syncpt timeout, syncpt = 74, err = -11
[ 2265.250049]
[ 2265.250049] vi2_capture_error_status
[ 2265.250068] TEGRA_CSI_CSI_CIL_A_STATUS 0x00000010
[ 2265.256518] TEGRA_CSI_CSI_CILA_STATUS 0x00040041
[ 2265.262581] TEGRA_CSI_CSI_CIL_B_STATUS 0x00000010
[ 2265.268100] TEGRA_CSI_CSI_CIL_C_STATUS 0x00000000
[ 2265.272828] TEGRA_CSI_CSI_CIL_D_STATUS 0x00000000
[ 2265.277754] TEGRA_CSI_CSI_CIL_E_STATUS 0x00000000
[ 2265.282825] TEGRA_CSI_CSI_PIXEL_PARSER_A_STATUS 0x00000094
[ 2265.288585] TEGRA_CSI_CSI_PIXEL_PARSER_B_STATUS 0x00000000
[ 2265.294821] TEGRA_VI_CSI_0_ERROR_STATUS 0x00000004
[ 2265.299791] TEGRA_VI_CSI_1_ERROR_STATUS 0x00000000
[ 2265.304961] TEGRA_VI_CFG_VI_INCR_SYNCPT_ERROR 0x00000000
[ 2265.310513]
[ 2265.310513] cam->ops->capture_start err: -11

Already some posts are there for the same error. But we don’t get any solutions.

Attached the full log file as well.

Please suggest us your valuable input to get around this error.

log_03_02_2016.txt (19.9 KB)

Hi Eswaran,

How many lanes of your ar1820 image sensor?
Are you referring the imx135_v4l2.c to develop your v4l2 driver?
How you configure your CSI port?

Thanks

Hi,

Thanks for your reply.

I configured for mipi 4 lanes and 10 bit raw data. Yes, I took imx135_v4l2.c as my reference driver and worked on that.

I am using yavta routine available on github.

As of now I am able to get raw image (3840x2160). But the errors are still there.

I am having the following issues currently.

  1. It takes 5 seconds to capture image (May be due to errors. It is giving errors still).
  2. I am not able to get pictures beyond 12MP resolution. I am getting memory allocation error. I need to configure for 18MP for which I need to allocate

Do you have any clues over this problems?

thanks & regards,
Kotteeswaran.E

Hi Eswaran,

From the errors, it seems there are some power rail level or configuration issue in your case.
You may refer to the following contents, and check them to see if any item not done well.

V4L2 User Guide for Jetson TK1
in Tegra_Linux_Driver_Package_Documents_R21.4 doc.

Wiki:
http://elinux.org/Jetson/Cameras#Building_your_own_custom_MIPI_CSI-2_camera_module

Thanks