Getting errors in using onboard camera (JetPack 3.1)

@JerryChang
Yes, it worked.
Thanks.
Anything else you would like me (or anyone who comes later to this thread) to know, regarding this issue?

hi
where is the path when typing

$ sudo ./flash.sh -r -k EBT jetson-tx1 mmcblk0p1

thank a lot ! I have spent 2 days on onboard camera !!

flash is the only way to fix this problem

How to use the attached file in these commands?

How did you execute it? what is the path?
should i put TX1 in recovery mood?

Yes, flash.sh implies doing that from host and put the TX1 in recovery mode (check from host you can see it with lsusb).
Your JetPack install on host has created a directory containing rootfs at <where_you_installed_JetPack_3.1>/64_TX1/Linux_for_Tegra_64_tx1. cd there. You’ll see a directory bootloader.
It contains a subdirectory for TX1 (t210ref). cd there. There is a file there named cboot.bin. You would have to replace it with the file in compressed archive attached to post #18 or simply click this link https://devtalk.nvidia.com/cmd/default/download-comment-attachment/73597/ save file in folder <where_you_installed_JetPack_3.1>/64_TX1/Linux_for_Tegra_64_tx1/bootloader/t210ref.
Then extract file from compressed archive:

tar xvf 1019986_cboot.tar.gz

Rename the extracted file 1019986_cboot.bin as cboot.bin (you may save the original one before):

mv cboot.bin cboot.bin.orig
mv 1019986_cboot.bin cboot.bin

Now you can go for flashing. Be sure your TX1 is in recovery mode and:

cd ..    #back to bootloader directory for flash tools
sudo ./flash.sh -r -k EBT jetson-tx1 mmcblk0p1

Check flash is ok, reboot TX1 and see if it’s ok.

I have the same issue on my TX1. I did the above replacing my cboot.bin and reflash but onboard camera still not working. Any help would be appreciated.

Camera Serial # 0324216018512
699-833326-1000-100 M
Below that on the board is 180-83326-DAAF-A01

Here is my boot file and UART boot messages file

klog.txt (58.8 KB)
minicomtx1.txt (82.9 KB)

Camera Serial No.jpg

hello randy.moore,

there’s no sensor board detected message shown in your bootloader messages.
are you able to reproduce the same issue with previous release image? i.e. JetPack 2.3.1 (R24.2.1)
thanks

I have flashed with JetPack 2.3.1 and attached the UART Boot Messages
minicom.jetpack-2.3.2.txt (86.4 KB)

Looks like it detected the device and the camera is working now

I Am getting this error now when using imagenet-camera googlenet and image-console. I thought it may be file corruption but downloaded multiple times with no luck.

Can you help resolve?

ubuntu@tegra-ubuntu:~/jetson-inference/build/aarch64/bin$ ./imagenet-camera googlenet
imagenet-camera
args (2): 0 [./imagenet-camera] 1 [googlenet]

[gstreamer] initialized gstreamer, version 1.8.3.0
[gstreamer] gstreamer decoder pipeline string:
nvcamerasrc fpsRange=“30.0 30.0” ! video/x-raw(memory:NVMM), width=(int)1280, height=(int)720, format=(string)NV12 ! nvvidconv flip-method=0 ! video/x-raw ! appsink name=mysink

imagenet-camera: successfully initialized video device
width: 1280
height: 720
depth: 12 (bpp)

imageNet – loading classification network model from:
– prototxt networks/googlenet.prototxt
– model networks/bvlc_googlenet.caffemodel
– class_labels networks/ilsvrc12_synset_words.txt
– input_blob ‘data’
– output_blob ‘prob’
– batch_size 2

[GIE] TensorRT version 2.1, build 2102
[GIE] attempting to open cache file networks/bvlc_googlenet.caffemodel.2.tensorcache
[GIE] cache file not found, profiling network model
terminate called after throwing an instance of ‘nvinfer1::CudaError’
what(): std::exception
Aborted

hello randy.moore,

since your camera is being probed and looks like its default function works.
could you file another new devtalk topics and let’s focus on that.
thanks

OK, created a new topic and posted.

Hi,

I’m experiencing the same issue on a TX2, is the patch provided TX1 specific, or can I flash it (with the appropriate changes to the command) to a TX2 as well?

I am facing the exact same position with on-board camera. The following is the error i get:

nvidia@tegra-ubuntu:~$ gst-launch-1.0 nvcamerasrc ! nvoverlaysink
Setting pipeline to PAUSED …

Available Sensor modes :
2592 x 1944 FR=30.000000 CF=0x1109208a10 SensorModeType=4 CSIPixelBitDepth=10 DynPixelBitDepth=10
2592 x 1458 FR=30.000000 CF=0x1109208a10 SensorModeType=4 CSIPixelBitDepth=10 DynPixelBitDepth=10
1280 x 720 FR=120.000000 CF=0x1109208a10 SensorModeType=4 CSIPixelBitDepth=10 DynPixelBitDepth=10
Pipeline is live and does not need PREROLL …
Setting pipeline to PLAYING …
New clock: GstSystemClock

NvCameraSrc: Trying To Set Default Camera Resolution. Selected sensorModeIndex = 1 WxH = 2592x1458 FrameRate = 30.000000 …

vid_rend: syncpoint wait timeout
'vid_rend: syncpoint wait timeout
'vid_rend: syncpoint wait timeout
'vid_rend: syncpoint wait timeout
'vid_rend: syncpoint wait timeout
'Received error from camera daemon…exiting…
Socket read error. Camera Daemon stopped functioning…
Got EOS from element “pipeline0”.
Execution ended after 0:00:17.415240171
Setting pipeline to PAUSED …
Setting pipeline to READY …
Setting pipeline to NULL …
Freeing pipeline …

Also, the samples provided for argus dont run either!

hello el15vmv,

this is a long topic for JetPack-3.1/TX1.

since we already had new JetPack release versions,
could you please have a try with latest release, please file a new topic if you still encounter issues.
thanks