Getting gst_rtspsrc_setup_auth () error when using rtspsrc element

whenever I try to play gst-launch-1.0 rtspsrc location="uri" ! fakesink
It throws couple of warning errors to me:

(gst-plugin-scanner:11388): GStreamer-WARNING **: 23:22:09.944: Failed to load plugin '/usr/lib/aarch64-linux-gnu/gstreamer-1.0/libgstlibav.so': /usr/lib/aarch64-linux-gnu/libgomp.so.1: cannot allocate memory in static TLS block

(gst-plugin-scanner:11388): GStreamer-WARNING **: 23:22:11.291: Failed to load plugin '/usr/lib/aarch64-linux-gnu/gstreamer-1.0/libgstchromaprint.so': /usr/lib/aarch64-linux-gnu/libgomp.so.1: cannot allocate memory in static TLS block
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Progress: (open) Opening Stream
Progress: (connect) Connecting to rtsp://user:passwd@192.168.1.1:554/h265/main/ch4/main/av_stream
Progress: (open) Retrieving server options
ERROR: from element /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0: Could not open resource for reading.
Additional debug info:
gstrtspsrc.c(5829): gst_rtspsrc_setup_auth (): /GstPipeline:pipeline0/GstRTSPSrc:rtspsrc0:
No supported authentication protocol was found
ERROR: pipeline doesn't want to preroll.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...

My device is Xavier NX running JP 4.5 and DeepStream-5.1

Before sharing feedback - I tried this: sudo rm ${HOME}/.cache/gstreamer-1.0/registry.aarch64.bin
It says no such directory

And tried,

But the solution didn’t work out.

Also - my tegrastats shows 6GB utilization without running anything.

I tried reinstalling gstreamer plugins but didn’t help either.

Looking for a solution - thanks

Hi,
There is a public URI and you can try and check if it works:

rtsp://wowzaec2demo.streamlock.net/vod/mp4:BigBuckBunny_115k.mp4

If the public URI works, your URI may be invalid.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.